[Plugin] Windows Phone Updated - New Tutorial!

Post your completed addons to share with the community

Post » Tue Mar 12, 2013 8:15 am

@tipztv oops, looks like I missed your last post - sorry!

Every solution will require you saving in-game variables to a remote service, then the tile retrieving that either automatically or through a remote push.

Scheduled local tile updates look like they could be added to the plugin viably, and would be a good way to notify users of new IAP or updates.

@devhammer Thanks for the info! Unfortunately the Azure Mobile Services plugin for Windows Phone isn't currently in the pipeline, but that may change depending on demand.
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Wed Mar 13, 2013 3:24 am

[QUOTE=thehen]
@devhammer Thanks for the info! Unfortunately the Azure Mobile Services plugin for Windows Phone isn't currently in the pipeline, but that may change depending on demand.[/QUOTE]

My pleasure. I'm still a relative noob to Construct 2, and I've yet to have a chance to dig into the plugin model, but I've done a http://bitly.com/bundles/devhammer/2 for apps using various parts of the Azure stack, including WAMS, so if I can be of assistance in moving a Mobile Services plugin forward, I'd be happy to help.


B
4
Posts: 11
Reputation: 477

Post » Wed Mar 13, 2013 4:42 am

@devhammer total highjack here... What's up buddy! This is James Waymire. I lectured with you for Microsoft way back in the day on Windows and .Net security before I started working there full time. When that team was run by Kai Axeford and Gina Davis! Small world. How have you been? I left about 1.5 years ago.BluePhaze2013-03-13 04:44:18
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,418

Post » Thu Mar 14, 2013 4:52 am

[QUOTE=thehen]
@devhammer Thanks for the info! Unfortunately the Azure Mobile Services plugin for Windows Phone isn't currently in the pipeline, but that may change depending on demand.[/QUOTE]

D'oh!

I see now that I misunderstood your original mention of your Windows Azure Mobile Services plugin, thinking it was related to this thread, rather than something else you were working on.

I did, however, run across the codeplex site for the plugin...will have to give it a try:

http://azureforc2.codeplex.com/
B
4
Posts: 11
Reputation: 477

Post » Thu Mar 14, 2013 4:56 am

[QUOTE=BluePhaze] @devhammer total highjack here... What's up buddy! This is James Waymire. I lectured with you for Microsoft way back in the day on Windows and .Net security before I started working there full time. When that team was run by Kai Axeford and Gina Davis! Small world. How have you been? I left about 1.5 years ago.[/QUOTE]

Small world, indeed, but I wouldn't want to paint it.

Still an FTE, still working in DPE, which is where I went after that tour. The main thing I miss about those days is the fact that I qualified for premier status on United, thanks to lots of short hops.

Haven't talked to Gina in a while...not sure if you knew, but after my wife and I had our first son, I sold my motorcycle to Gina (to make room for a 2nd car). Good times!
B
4
Posts: 11
Reputation: 477

Post » Sat Mar 16, 2013 2:36 am

@thehen I keep getting this error:
An exception of type 'System.IO.FileNotFoundException' occurred in Microsoft.Xna.Framework.ni.dll but was not handled in user code

And this highlighed green: Stream stream = TitleContainer.OpenStream(file);

I already check everything multiple times, made sure that WindowsPhoneExample/media/ is there and contains correct WAV files. (music.wav & sound.wav)

and replaced original files with the files that are in Extra Files folder.

The back function works perfect, but the sound and music doesn't work.

What am i doing wrong?

Thank you
Stan
B
17
S
6
Posts: 39
Reputation: 1,662

Post » Sat Mar 16, 2013 12:32 pm

@Dgsstan if you can pm me a link to the exported project I'll take a look.
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Sat Mar 16, 2013 7:44 pm

@thehen yes here is the link: https://www.dropbox.com/s/06xb4i23us3l506/WindowsPhonePlugin.rar


Thanks
Stan
B
17
S
6
Posts: 39
Reputation: 1,662

Post » Sun Mar 17, 2013 2:49 am

@Dgsstan you need to add the media folder to the solution. From the description:

"Visual Studio will open up and you should see the solution explorer on the right. One of the icons at the top is called Show all files, make sure that is selected. Right click on the media folder and select include in project."
Moderator
B
72
S
13
G
11
Posts: 900
Reputation: 11,783

Post » Sun Mar 17, 2013 7:17 pm

@thehen Thank you :D that worked.
B
17
S
6
Posts: 39
Reputation: 1,662

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: No registered users and 3 guests