[plugin] Youtube player

Post your completed addons to share with the community

Post » Fri Jun 24, 2016 9:23 am

@Pandy

I did not find the solution on google.
B
109
S
27
G
277
Posts: 4,482
Reputation: 154,924

Post » Fri Jun 24, 2016 11:27 am

@rexrainbow Ah, ok. No worries. You're doing an awesome job with your plugins and all. Thanks for all of it.
B
16
S
4
Posts: 142
Reputation: 1,462

Post » Sun Jun 26, 2016 4:08 pm

@rexrainbow

Hey, the Playback event - Video cued does not seem to fire. I put in some actions to test it and it does not work. For me at least. the video loads and plays and ends but the even for the event 'on playback event - video cued' does not seem to work.

And in load video, the set autoplay to no/yes also does not seem to work. I put load video and set autoplay to no, but it plays it anyway. Only the initial setting of no autoplay works. If I load a new video or create a new YT object and load video, the 'autoplay-no' does not work.
B
16
S
4
Posts: 142
Reputation: 1,462

Post » Sun Jun 26, 2016 5:23 pm

@rexrainbow

One more question, is it possible to prevent player from clicking the YouTube logo and send the browser to the youtube page?
B
22
S
4
G
3
Posts: 64
Reputation: 2,689

Post » Mon Jun 27, 2016 2:13 am

@Pandy

1. "Condition:On playback event" is fired from youtube api, "Video cued" will not fire if client does not get "onStateChange" and state = video cue.
I had tested it but could not find that event either.

2. I tested action load with auto-play=No in this capx, it worked fine. You might update this youtube plugin then try it.
( Use this tool to check the updating status of my plugins )
B
109
S
27
G
277
Posts: 4,482
Reputation: 154,924

Post » Mon Jun 27, 2016 2:37 am

Update

Add property "Modest branding". Set "Modest branding" to "Yes" to remove youtube logos.



@Tuiii
Removing youtube logos (set "Modest branding" to "Yes") might prevent clicking the YouTube logo.
B
109
S
27
G
277
Posts: 4,482
Reputation: 154,924

Post » Tue Jun 28, 2016 3:34 pm

rexrainbow wrote:Update

Add property "Modest branding". Set "Modest branding" to "Yes" to remove youtube logos.



@Tuiii
Removing youtube logos (set "Modest branding" to "Yes") might prevent clicking the YouTube logo.


Didn't work :(
I set Modest branding to Yes but the logo and this little info button are still there:
Image

It works when Show info is enabled, but again it would be possible to click the video info and go to the youtube page.
B
22
S
4
G
3
Posts: 64
Reputation: 2,689

Post » Tue Jun 28, 2016 4:27 pm

@Tuiii

"It works when Show info is enabled", right. I saw that result in my test.
Unfortunately there is no direct way to remove youtube logo -
In this reference, someone provided JULBUL to fully customize the skin of youtube. (it is not free)
B
109
S
27
G
277
Posts: 4,482
Reputation: 154,924

Post » Thu Jun 30, 2016 1:41 am

I see... Well, thanks anyway! Keep up the great work!
B
22
S
4
G
3
Posts: 64
Reputation: 2,689

Post » Thu Jul 07, 2016 5:49 pm

@rexrainbow

My android phonegap build fails to play the video. This is the error - The video contains content from WMG. It is restricted from playback on certain sites.

It works when I am previewing in browser and also under WebView of CocoonJS Developer app. However, the compiled app shows this error. Can you help?
B
2
Posts: 3
Reputation: 156

PreviousNext

Return to Completed Addons

Who is online

Users browsing this forum: No registered users and 2 guests