Porting to C2 - node webkit - doable?

Discussion and feedback on Construct 2

Post » Wed Jun 19, 2013 12:44 am

Chrome is better than node-webkit on Mac (my game is mostly black with node-webkit but runs perfect in Chrome), which is something to keep in mind.
B
147
S
73
G
20
Posts: 1,785
Reputation: 22,420

Post » Wed Jun 19, 2013 1:09 am

Yeah, apparently Node-Webkit has issues on Mac and Linux ATM but I can't imagine that continuing for too long.
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Wed Jun 19, 2013 12:05 pm

Purchased a personal license.

Wish me luck ;)

Anyway, big thumbs up for Scirra and this awesome and supportive community!
Image
B
17
S
5
G
1
Posts: 122
Reputation: 1,930

Post » Thu Jun 20, 2013 3:07 am

YAY the Mac Node-webkit is now working really well! (with the 0.6 update that came with C2 r135)alspal2013-06-20 03:20:59
B
147
S
73
G
20
Posts: 1,785
Reputation: 22,420

Post » Thu Jun 20, 2013 4:23 am

Awesome, good to hear!
Moderator
B
94
S
33
G
33
Posts: 3,006
Reputation: 27,744

Post » Thu Jun 20, 2013 4:38 am

Excellent! Any news on Linux? Anyone have a linux box to test?
B
92
S
31
G
24
Posts: 3,191
Reputation: 32,679

Post » Thu Jun 20, 2013 6:09 am

Ya if anyone has a Linux computer, and would be up for testing I'd like that too.
B
147
S
73
G
20
Posts: 1,785
Reputation: 22,420

Post » Thu Jun 20, 2013 1:26 pm

Good to hear about Mac support! The node-webkit 0.6 release notes mention "In this release, Chromium is updated to 28.0.1500.11. This fixes a
number of serious bugs on OSX for CSS and canvas animation in upstream
content shell. " - sounds like it must have been to do with that.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Thu Jun 20, 2013 5:13 pm

I don't experiment too much with Ubuntu (Forgot the version, 11.something), I do have it installed via Wubi, so I booted into it and ran a newly exported project that had WebGL enabled on export. It worked fine! But WebGL effects weren't showing up (iirc WebGL worked in previous tests I done weeks ago, though maybe I tinkered with settings in Ubuntu or something)
B
51
S
20
G
10
Posts: 571
Reputation: 9,819

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests