Possible Autosaving problem?

Discussion and feedback on Construct 2

Post » Thu Feb 06, 2014 12:12 pm

First of all, I'm not reporting this as a bug as I still don't know if there's something wrong with the program, my computer, or anything else, and I just want to know if anyone else is experiencing the same problem.

So, as far as I know, Construct 2 makes new files with .autosave and .backup to keep your work safe. Whenever the program makes this, the real project is not saved at all and you have to save it manually so it updates your project or file.

What I have noticed is that sometimes, mostly after I leave my computer with Construct running unatended for some time, when I come back the name of the file Construct is saving to (which appears on the top of the screen after Construct 2 rXXX - Project name - Level name), changes to Project name.autosave.
If I do save then, the file saved is the autosave, and not the real project, which has caused me already to lose some progress, because it seems like I can't change that so it updates my main file instead of this autosave.

Also, but I don't know if it is related or not, when Construct changes the file I'm working into to this autosave, I get lots of errors trying to test my game, the most usual being no sound and sudden crashes.

I'm thinking that something happens if you leave Construct running unattended for some time, so that it stops working on your project and switches file to an autosave one. Has anyone else experienced anything like this?
B
9
S
4
G
2
Posts: 12
Reputation: 2,772

Post » Thu Feb 06, 2014 1:49 pm

Does this happen with a folder project, .capx project, or both? Can you reproduce it if you set the autosave interval to 5 minutes and leave it for 10-15 minutes?
Scirra Founder
B
402
S
238
G
89
Posts: 24,628
Reputation: 196,023

Post » Thu Feb 06, 2014 2:44 pm

Sure, I'll try. The times it has happened to me I had a folder project, one with lots of levels and event sheets. I'll try to make some tests and get back to you with the results.
B
9
S
4
G
2
Posts: 12
Reputation: 2,772

Post » Thu Feb 06, 2014 4:18 pm

I have run a couple of tests, setting the interval at 5 minutes. The first time, after about 20 minutes, the title of the construct 2 windows changed the project name to project name.autosave, and trying to exit and then save gave me an error (I took a screenshot of it and will post a full bug report later). The second time, It took more than an hour of leaving my computer unattended until the same happened.

I've noticed anyway that when the autosave kicks in, the title of the Construct screen changes to Prpject name.autosave for a moment (while saving it) and then changes back to Project name. So I guess something happens sometimes that doesn't switch the target file and gets messed up.

Anyway, I'll try to write a bug report on the bug forum later, as I can't do it right now.
B
9
S
4
G
2
Posts: 12
Reputation: 2,772

Post » Wed Dec 09, 2015 5:46 pm

I have the same problem. Is there any solution?
B
4
Posts: 1
Reputation: 202

Post » Wed Dec 09, 2015 5:50 pm

@renate
renate wrote:I have the same problem. Is there any solution?


This thread is nearly 2 years old, so I doubt your problem is the same.

It would probably be better if you started your own thread and if at all possible, make a small .capx that highlights the problem. That will allow other users to help you more effectively and maybe determine if it is an actual bug that would need the attention of Ashley.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,545
Reputation: 60,434


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 3 guests