Possible bug: On object clicked + scrolling

New releases and general discussions.

Post » Thu Oct 16, 2008 8:29 pm

Edit:
Sorry, I was in hurry and didn't notice the "Where to submit bug reports" sticky thread. :cry:
and, Ashley, I erroneously put my mail address in the details of the bug tracker (bug number 2172847), could you please wipe it out so I won't receive tons of spam, thanks.

Hello, my first post here!
I think I spotted a possible bug.

In Layout
-Add a sprite (a filled square will suffice)
-Add a Mouse-Keyboard object
In Event sheet
-Add a Mouse event of type "On object clicked", set the sprite as a target for the event
-Add an action for this event, say "Set angle to 45" for the sprite

Now run the layout and everything should go fine (click the sprite, the sprite turns 45)

Ok, now:
-Add a system event "Always"
-Add to this event an action "System - scroll to object", with the sprite as a scrolling target

Now run the layout, click the sprite and... nothing happens! It seems like the clicks aren't recognized anymore.
I don't know if this is a bug, I'm new here and maybe I'm missing something.

Beside that: wonderful application! Wonderful, wonderful wonderful!

Leo
B
1
G
4
Posts: 1
Reputation: 1,027

Post » Thu Oct 16, 2008 9:22 pm

Huzzah! You found the bug I was trying to find in one of my games.

This is an issue with the collision mask - or something like it - because if you do the steps you mentioned then click in the middle of the layout when it's running (where the sprite would be if it could scroll to it), the sprite rotates.

It's like the collision mask has 'unbounded scrolling' on, even though the layout doesn't.
Moderator
B
88
S
32
G
33
Posts: 3,005
Reputation: 27,422


Return to Construct Classic Discussion

Who is online

Users browsing this forum: No registered users and 5 guests