Possible bug? TextBox does not recognise being clicked on

Discussion and feedback on Construct 2

Post » Fri Aug 25, 2017 9:44 am

Hi!

I'm trying to set a variable whenever a textbox is being clicked on, but no matter what I do to detect the click, the actions in the event will not fire.
But, it will detect whenever the mouse DOESN'T click on the textbox, and when it hovers over it.

I've tried this on both latest stable version, and latest beta version.
Here's what I've tried:

On left button clicked on -> TextBox : DOESN'T fire
(I left click on the textbox)

On left button clicked
Cursor is over -> TextBox : DOESN'T fire
(I hover over the textbox and left click)

Cursor is over -> TextBox : DOES fire
(I hover over the textbox)

On left button clicked
Cursor is NOT over -> TextBox : DOES fire
(I have my cursor outside of the textbox and left click)'

Left button is down
Cursor is over -> TextBox : DOESN'T fire
(I hover over the textbox and left click)

I also tried putting conditions in different orders, that didn't work either, and I've tried disabling any other events but these to see if something is conflicting, but it didn't work either.
If someone else could try this and see if they can replicate the problem, then I know it's not just mine that's doing this.
It's just weird that it can detect when it's not being clicked on, but not when it is.
Image
B
12
S
3
Posts: 40
Reputation: 847

Post » Fri Aug 25, 2017 11:29 am

The TextBox 'steals' the mouse. That is why the TextBox has its own condition > On clicked.
Start from the TextBox (not form Mouse) to add the condition.
B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Fri Aug 25, 2017 11:52 am

Ah, I see now. Thanks!
Image
B
12
S
3
Posts: 40
Reputation: 847


Return to Construct 2 General

Who is online

Users browsing this forum: Yahoo [Bot] and 9 guests