Possible problem with Touch and Windows 8 Plugin

Discussion and feedback on Construct 2

Post » Fri May 01, 2015 1:34 pm

Hi. I have a Sprite as Background and added 2 Text objects above on the left and right side with an Arrow in it to scroll through Images.
Image

I used the following code which seem to work fine in browser preview:
Image

But when I run this as Windows App in Visual Studio Preview a click on the arrows sometimes (not always!) opens the link of the sprite behind it.
Did anyone else ever try something like this and noticed this odd behavior? (C2 r200 (stable))

I tried to make a new Project to check if it is a bug and submit the .capx but in a completely new Project with just 1 sprite and 1 text it did not have this issue (but it had only on tap gesture + inverted in touch with text)
Bl4ckSh33p-Soft - Custom Software and Indie Games
B
55
S
16
G
6
Posts: 727
Reputation: 9,253

Post » Sat May 09, 2015 9:20 pm

Hi! I think I found the reason for this issue. When I open a link for the first time Internet Explorer is docked to the right to Show the Weblink. And when I Close it clicking on the right "next" arrow always opens the banner link. When I Switch back to the Desktop and then back to the app again clicking on the next arrow does not open a new IE window as it should. So it seems to be an issue with resizing the app and then not properly recognizing where you click/touch.

Is there a way to fix this?
Bl4ckSh33p-Soft - Custom Software and Indie Games
B
55
S
16
G
6
Posts: 727
Reputation: 9,253


Return to Construct 2 General

Who is online

Users browsing this forum: JesusJ and 16 guests