Previewer slow/lag

Discussion and feedback on Construct 2

Post » Sat Nov 16, 2013 8:00 pm

Hi all,

I am new to Construct 2. I am excited and working my way through tutorials. While working through tutorials I've run into previewer troubles - the previewer becomes gummed up with extreme lag.

My first tutorial (Beginner's guide to Construct 2) started fine, then, in between switching from creating an event and testing that event I noticed the previewer started to slow down drastically, almost to a complete halt. I researched the forums and found the "trouble shooting construct 2's preview server" topic and discovered the problem at the time to be my browser. I switched from internet Explorer to Chrome and it resolved the problem.

I've started my second tutorial (How to make a platform game). I progressed to "adding an enemy", selected the "run layout" to preview the game and the lag came back. I checked my browser to make sure it was still Chrome (it was).

I've now gone through the list of "troubleshooting construct 2's preview server". I've also read through several other forums about dealing with chrome directly. Ex. tried Firefox, checked firewall, changed port etc.

No success.

Any help is greatly appreciated! I'm excited to get past this hiccup and carry on with fun stuff!

My specs if needed:
macbook pro retina
64 bit windows 7 via parallels (I run cad programs with success)
16 gb ram, 4gb dedicated to parallels
2.6 GHz intel i7
google chrome
java version 7, update 45
B
4
S
2
Posts: 3
Reputation: 483

Post » Sat Nov 16, 2013 8:19 pm

I guess CAD-programs, as mostly vector-based programs are not good to compare. PLS correct me, if im wrong. Did you ever render something using parallels? Like a movie or a 3D-model with ligt added etc?

I guess parallels is always a pretty bad thing. I would highly recommend to make an own partition using bootcamp. Makes everything a lot more stable. :)

Did you ever try another preview browser? Perhaps its an ie and chrome-based problem.
Safari works pretty good for me :)
Good luck!

Beaverlicious2013-11-16 20:20:52
Image
Check out our start-up and configure your own helmet in true 3D.
B
45
S
12
G
11
Posts: 1,154
Reputation: 10,093

Post » Sat Nov 16, 2013 10:09 pm

Is it also launching Chrome within Parallels? VMs sometimes have pretty poor performance, since they don't support GPU acceleration and will give you software rendering. Maybe previewing from Chrome running back in OS X will work? If not, maybe using preview-over-LAN mode?
Scirra Founder
B
402
S
238
G
89
Posts: 24,632
Reputation: 196,041


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 3 guests