Problem deleting layer

For questions about using Classic.

Post » Tue Feb 03, 2009 4:15 pm

Maybe I am missing something. But if I remove de "Reflections" layer in my project I cant run the preview later. I am doing something wrong, or it is a bug?
[url:2l65bbvj]http://dl.getdropbox.com/u/472186/Construct/Forums/demo04LayerBug.cap[/url:2l65bbvj]
B
31
S
15
G
10
Posts: 285
Reputation: 7,169

Post » Tue Feb 03, 2009 4:38 pm

For some reason, the Mouse & Keyboard object thinks it's on the "Reflections" layer. That's kind of a bug, since it shouldn't belong to any layer. When you delete the layer, the Mouse & keyboard object is deleted, which deletes all conditions relating to Mouse & keyboard, which includes the event "On escape pressed - close application", which leaves a blank event with a close application action. Since a blank event runs always, your application issues a Close action on startup.

I'm not sure how the mouse & keyboard object ended up on a layer. It might be a bug, I'll investigate.
Scirra Founder
B
362
S
216
G
75
Posts: 23,067
Reputation: 180,331

Post » Tue Feb 03, 2009 4:40 pm

Looks like this cap was made with a version of Construct without stringent checks on where objects get created.

Can you verify how old this file is?

Thanks
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Tue Feb 03, 2009 4:45 pm

I have not noticed the Mouse & Keyboard-Layer relation. Thanks Ashley.

[quote:svwzrbzk]Can you verify how old this file is?[/quote:svwzrbzk]

No, I cant. The first cap file was deleted, and this one is recently created. But I supposed is 1-2 months old... :? Cant say exactly.
B
31
S
15
G
10
Posts: 285
Reputation: 7,169


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 5 guests