problem with colision detection

Bugs will be moved here once resolved.

Post » Mon May 20, 2013 11:41 am

Link to .capx file (required!):
https://dl.dropboxusercontent.com/u/169390986/PUB/error.capx

Steps to reproduce:
1. use arrow keys to rotate green box to marked "area of colision"

Observed result:
green box records colision with player but i have wierd colision detection also on the oposite side of the screen (area is marked)

Expected result:
well colision shud be only detected with player

Browsers affected:
Chrome: not tested
Firefox: yes
Internet Explorer: yes

Operating system & service pack:
Win 7 pro 64(up to date)

Construct 2 version:
126 and i just upgraded to 130
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Post » Mon May 20, 2013 4:24 pm

Can you reproduce this in a more reliable way? It is extremely difficult to debug issues which occur randomly. If you can make an example which shows incorrect collision on start of layout, we can probably solve the problem immediately, but with your current example it could take a very long time before we can fix it.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,208

Post » Mon May 20, 2013 4:51 pm

Hm i dont know hot to describe it more precise...
It happens every time when a green box is entering a marked area from left to right.
(from 11 o'clock to 12 o'clock movement)

See this jpeg:


PS:

And i see it happens if it's moved from right to left also.

:(irina2013-05-20 19:21:28
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Post » Mon May 20, 2013 7:21 pm


Updated!

https://dl.dropboxusercontent.com/u/169390986/PUB/error.capx

just use arrow keys when box is in the areairina2013-05-20 19:22:14
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Post » Tue May 21, 2013 2:50 pm

Ashley... do you have any update on this issue?
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Post » Tue May 21, 2013 4:44 pm

We're a small team and very busy, please allow 1-2 weeks for issues to be properly investigated.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,208

Post » Tue May 21, 2013 4:55 pm

Ok, ok :(
I know, patience is a virtue... that im lacking.irina2013-05-21 16:55:37
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Post » Thu May 23, 2013 3:37 pm

Your example is still extremely difficult to diagnose because it doesn't reproduce reliably, unless you press keyboard input. Can you make an example that reproduces it without requiring any user input at all? And it would be even better if nothing is moving, and it reproduces immediately on the start of the layout.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,208

Post » Fri May 24, 2013 9:50 am

I am sorry but you must realize that mine knowledge of Construct and mine programing skills are very limited. I'w purchased licence like 2 weeks ago.
This is not something iw made... its something that is happening unexpectedly...       
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Post » Fri May 24, 2013 10:16 am

I'w done some changes...
Take a look at those 2 examples:
https://dl.dropboxusercontent.com/u/169390986/PUB/error-2.capx
https://dl.dropboxusercontent.com/u/169390986/PUB/error-3.capx

i'w only changed my size formula

Set size to (self.Width + rotSpeed *dt /3, self.Height + rotSpeed *dt /3)
Set size to (self.Width + rotSpeed *dt /2, self.Height + rotSpeed *dt /2)

And area of contact has shifted to the right.


irina2013-05-24 13:52:45
B
26
S
11
G
2
Posts: 669
Reputation: 5,038

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests