Problem with game performance

Discussion and feedback on Construct 2

Post » Fri Aug 17, 2012 11:02 am

Hello,

I'm making a very simple test to check the permformance of a game and it seems to run slow.

Game: http://ethemba.com/TOOLS/gamecenter/pruebas/basic
Capx: http://ethemba.com/TOOLS/gamecenter/pruebas/basic/basic.capx

- Is it normal for such a simple game I have performance problems?
- Could you test the game in your computers and tell me if it runs smoothly?
- Am I doing something wrong?

I've tested with Firefox 14 and Chrome 21. I have Windows 7 (64 bits), 3'40 GHz and 8 GB RAM.

I would appreciate any advice :)

Thank you
B
3
Posts: 27
Reputation: 904

Post » Fri Aug 17, 2012 11:16 am

something must be wrong on your end, I'm getting a solid 60 FPS and my computer is nearly 6 years old.

I'm also on a 64 bits win7 ultimateFimbul2012-08-17 11:16:54
B
35
S
8
G
8
Posts: 532
Reputation: 6,868

Post » Fri Aug 17, 2012 11:36 am

ok first of all i think your graphic card is too old or something like that or its not up to date .. check it

2nd thing this game is really smooth i even get more than 60 fps on chrome and IE and this is a picture if you wanna see :

this picture from google chrome (latest version)

by the way i used my 4 years old laptop with 4 gb ram , and windows 7 32bit
B
45
S
15
G
6
Posts: 795
Reputation: 11,935

Post » Fri Aug 17, 2012 10:53 pm

Have you considered the following:

-Virus Scan, Programs or pop-ups running in background.
-Haven't cleared cache for a long time.
-Updated appropriate drivers/browsers.
-Tested game with fewer tabs open.
-Exported game then tested it.
-Considered webhost of game.
-Absence of apple pie and tea while playing game.

For myself I get an average of 59 fps (58-60), and that's while running a laptop which professes an obvious hatred for me and anything associated with game design.
B
85
S
31
G
14
Posts: 106
Reputation: 16,440

Post » Sat Aug 18, 2012 2:37 pm

Solid 60 FPS here as well, in Chrome.

The most likely cause is your graphics card drivers are out of date and the browser is falling back to software rendering. Try updating your graphics drivers.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Sat Aug 18, 2012 3:17 pm

I benchmarked a 64fps on Chrome. Something must be up on yer end.VampyricalCurse2012-08-18 15:17:49
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Sat Aug 18, 2012 7:31 pm

> 60FPS most of the time.
As Ashley said, its probably your graphics card.

If you need this though, HERE is a manual with tips on speeding up your game.
B
36
S
10
G
6
Posts: 948
Reputation: 11,101

Post » Mon Aug 20, 2012 12:41 am

OK
Thanks. We have tested it in 15 computers, in local and online, and with no good results. Many variations and always the freeze.

Finally I have made another version using physics which has better response so i will use this one instead. The movement is better, I dont really know why.

I have two new problems in that version, but i will ask in a new thread not to confuse questions

Thanks all for your interest.



B
3
Posts: 27
Reputation: 904

Post » Mon Aug 20, 2012 4:42 am

60 FPS on Chrome (4 years laptop) and 300 to 500 FPS on IPAD 1 (appMobi export with Direct Canvas).

Are those 15 computers on the same LAN?
B
29
S
6
G
5
Posts: 148
Reputation: 5,084

Post » Mon Aug 20, 2012 6:21 am

Those 15 computers must be really messed up.. it seems to run very well on all our machines.
B
36
S
10
G
6
Posts: 948
Reputation: 11,101

Next

Return to Construct 2 General

Who is online

Users browsing this forum: Eisenhans and 15 guests