Problem with: How to make a platform game tutorial

Get help using Construct 2

Post » Tue Jun 12, 2012 7:10 pm

Hi Guys,

Complete newbie here, just started today, so sorry if this problem have been brought up before, but I couldn't find any previous topic about it.

I have been following Ashley's tutorial to page 6 and just finished setting up the Character animation. Not sure if this tutorial is so old that it doesn't work correctly with latest build of Construct 2?

But for some reason when I am jumping from standing (JumpFromStand) no animation is played out on the screen. However (JumpFromRun) works fine.
One other things that also seems not work correctly is when landing on a platform and keep on pressing forward the character just starts sliding instead of running.

I am lost to why the animation is not working properly, I am pretty sure I have not messed up, as I have been following the tutorial 100%.

Here is the .capx file.

Thank you in advance for any help provided.Tsengar2012-06-12 19:17:36
B
58
S
28
G
7
Posts: 13
Reputation: 6,203

Post » Tue Jun 12, 2012 7:35 pm

Animations "idle" and "run" are triggered by the same condition - platform is moving.
You should invert the one with "idle".

Kastas2012-06-12 19:40:26
B
79
S
32
G
23
Posts: 119
Reputation: 14,937

Post » Tue Jun 12, 2012 7:45 pm

@Kastas is right, as they stand your events read "Platform is moving: set 'Run' animation - Platform is moving: set 'Idle' animation". Maybe you missed this part of the tutorial on page 6:
[quote]To make the above event you'll also need to invert a condition (appearing as the red cross). Inverted conditions mean the opposite of what they state. In this case, the inverted "Platform is moving" condition then means "Platform is NOT moving". To invert a condition, add it normally, then right-click on it and select Invert. Alternatively, select it and press I.[/quote]
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Tue Jun 12, 2012 7:45 pm

Hmm, looks like I didn't read the tutorial 100% after all, not sure how i missed that, I been reading that page over and over now so many times.

Thanks a lot Kastas, that helped.

To tired i guess
B
58
S
28
G
7
Posts: 13
Reputation: 6,203

Post » Sun Feb 03, 2013 9:58 am

Hello every one, this is my first time here, enjoying the program very much, I'm currently going through the how to make a platformer tutorial and have run into a problem on this page like the original poster.

http://www.scirra.com/tutorials/253/how-to-make-a-platform-game/page-6

I can't get the jump from standing animation to activate, whenever the platform jumps it always plays the jumpFromRun animation, here's a screenshot of my events sheet, as far as I can tell It's correct but I would appreciate any help pinpointing where I've gone wrong.





Many thanks and sorry for digging up an old thread.

Matt
B
3
Posts: 2
Reputation: 329

Post » Sun Feb 03, 2013 11:27 am

It looks like "Platform on jump" is always moving so sub-event "Platform is not moving" is never true.

Works like that
B
79
S
32
G
23
Posts: 119
Reputation: 14,937

Post » Sun Feb 03, 2013 3:41 pm

Thanks that did the trick, i had a feeling that jumping should count as moving but wanted to follow the tutorial by the letter, but I guess it might have been from an older version.

Thanks again.
B
3
Posts: 2
Reputation: 329


Return to How do I....?

Who is online

Users browsing this forum: 99Instances2Go and 25 guests