Problem with loader layout and update progress

Discussion and feedback on Construct 2

Post » Mon Feb 02, 2015 1:35 pm

Hi. Until the last Update I just showed a progress bar and text when "is downloading update" was fired. But I added a new loading screen and now it seems if there is an update it always shows the loading screen, load all new updates and then proceed when "on loader layout complete" fires. It seems this is the same as "On Update ready" because loadingprogress is 1 for both cases.

I tried to change/show some text when an update is loaded but the text does not update and always shows the default text even if an update is loading and the progress bar is moving. I tried a few things with variables and wait commands but could not find a solution, yet. It seems "Is downloading Update" is also fired when the game is loaded for the first time. Is this right? :?:

Image
Bl4ckSh33p-Soft - Custom Software and Indie Games
B
57
S
17
G
6
Posts: 751
Reputation: 9,451

Post » Mon Feb 02, 2015 6:24 pm

I dont know why but it showed the proper "Downloading update" text a few times now, but the code did not change. o.O
I added some Wait commands to simulate animated text and will continue to test it tomorrow.

Current code:
Image

But I would still be glad to hear about your own experiences with custom loadingscreens and if there have been issues.
Bl4ckSh33p-Soft - Custom Software and Indie Games
B
57
S
17
G
6
Posts: 751
Reputation: 9,451


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 4 guests