Problem with Node-Webkit

Discussion and feedback on Construct 2

Post » Thu Dec 18, 2014 6:05 pm

Yes, you are right. Just tested it and if I remove the multiply effect it gets ok. But I need it to be with Multiply, because of the slight contour it makes.

What puzzles me is if I create the same situation in another project, even with multiply, it works fine...
B
12
S
3
G
1
Posts: 120
Reputation: 1,829

Post » Thu Dec 18, 2014 6:08 pm

Yes @Aphrodite I tried installing that too, nothing changed.
B
12
S
3
G
1
Posts: 120
Reputation: 1,829

Post » Thu Dec 18, 2014 6:27 pm

This is what i see in Chrome..
You do not have the required permissions to view the files attached to this post.
B
48
S
16
G
9
Posts: 1,097
Reputation: 11,195

Post » Thu Dec 18, 2014 8:24 pm

@Aphrodite yes it's white because of the Blend mode/webGL effects.. the image is actually white and the effect makes it transparent.

when I disable the webeffects and make the blend mode normal I don't get the distortion..
B
97
S
32
G
16
Posts: 1,199
Reputation: 16,680

Post » Fri Dec 19, 2014 2:00 pm

Well in the end I managed to make it work. If anyone else is experiencing this I found that the Sprite with the mask is bugged somehow, because if I delete it and make another with the same effects and blending modes, it works.

Thanks a lot guys for your help.
B
12
S
3
G
1
Posts: 120
Reputation: 1,829

Post » Fri Dec 19, 2014 2:14 pm

And now I know whats wrong with the Mask Sprite

Apparently if that mask has more than 1 animation, It bugs. Looks to me like a bug @Ashley
B
12
S
3
G
1
Posts: 120
Reputation: 1,829

Post » Fri Dec 19, 2014 2:48 pm

@Pakost - if it's system specific, it very strongly suggests a driver bug. If it works correctly on other systems that kind of proves it's not a bug in C2 or the browser.
Scirra Founder
B
395
S
232
G
88
Posts: 24,371
Reputation: 193,762

Post » Fri Dec 19, 2014 4:07 pm

Ok cool

I got it worked around anyways :)

Again thanks for everybody's attention
B
12
S
3
G
1
Posts: 120
Reputation: 1,829

Post » Fri Dec 19, 2014 5:23 pm

@Pakost

What did you do ?
B
76
S
22
G
14
Posts: 389
Reputation: 12,249

Post » Fri Dec 19, 2014 10:17 pm

@tumira
Well i removed the second animation, and created another sprite with it
B
12
S
3
G
1
Posts: 120
Reputation: 1,829

Previous

Return to Construct 2 General

Who is online

Users browsing this forum: Artpunk and 5 guests