Problem with "On Collision"

Get help using Construct 2

Post » Sun May 26, 2013 2:04 am

Imagine a rocket with 3 sections. The Bounding Box encompasses section 3 and nothing else.


1 - |
2 - |
3 - |


The rocket travels upwards towards Object1.
I'm using the Pin(Position & Angle) behavior so that Section 3 "On Colision" with Object1, should freeze.

My problem is that it freezes when Section 1 collides with Object1, rather than Section 3.


The Bounding box on Object1 is no bigger than the object either, so it shouldn't be happening.


Does anyone know why it's happening?



EDIT : It seems to take the top edge of the visibly drawn image as Collision box for the Rocket, and the Bounding Box for Collision box for Object1. Why?Xionor2013-05-26 02:15:09
B
10
S
3
Posts: 233
Reputation: 1,537

Post » Sun May 26, 2013 2:14 am

It depends on how you've set things up. Post your capx and we should be able to give you a more precise answer.

Maybe it's because your collision polygon is not the same in every frames, maybe it's because your three sections are only one object type, maybe it's even something else. Can't know and tell you without having an eye on your project.

New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,999
Reputation: 57,793

Post » Sun May 26, 2013 2:19 am

Dear Kyatric, THANK YOU!

The image was supposed to be single frame, but apparently a copy of it had somehow snuck itself into the Animation Frames.

They had different bounding boxes and that's where the issue came from.


B
10
S
3
Posts: 233
Reputation: 1,537


Return to How do I....?

Who is online

Users browsing this forum: luckyrawatlucky, mindragon73 and 29 guests