Problem with pathfinding after layout change

Get help using Construct 2

Post » Sat Sep 21, 2013 11:39 am

Hello everyone. I have almost completed my entry project for Tulamides A Blossom Tale event, but am encountering a peculiar problem.

I have a main menu where you can set difficulty, see credits & instructions etc. When you press start, you change layout to gameplay area. Here I use pathfinding to move various objects around.

The problem is, pf doesn't work after the layout change. But if I run the gameplay directly from that layout, it works. I have searched the forums and found this was actually a bug, but Ashley reported it fixed. Is it back to haunt us? Is it sinisterly waiting in the shadows to hunt down important projects in the last minute? Or is it my inability to properly switch layouts?

Anyone has any idea or similar problems?

EDIT: I tried to simulate the anomaly in a new project, but it works there. I suspect it may have to do with music, preloading, or sth else that I broke...

EDIT2: Debugging shows they are stuck in "calculating path"

EDIT3: It certainly is about the music/sounds. Because when I disabled all music and sound, it works perfectly. When I play the music, it still works. But as I keep adding sounds, after some point, it doesnt. I think it may be related to chrome. Unfortunately I only use chrome so didnt have the chance to test on other systems. (IE is completely unplayable with my program) I will post the capx after the competition end, and we shall see better then...

Regards;
-Wind.Windwalker2013-09-21 13:11:17
B
18
S
4
G
1
Posts: 332
Reputation: 3,149

Return to How do I....?

Who is online

Users browsing this forum: Artcadev and 6 guests