Problem with solid items

Get help using Construct 2

Post » Wed Apr 20, 2016 9:36 am

So I have a problem in my platform game. I made some new solid boxes. Here's a picture:

http://www.pic-upload.de/view-30413452/boxbug.png.html

But they are not really "solid". You can see it on the picture. The left side from the box is solid till the top of the box.
But on the right side, the solid part just start in the middle from the box.. Where's the problem?
I also made other items like the box with a solid behaivor and it worked perfect...
Thanks!
B
27
S
10
G
3
Posts: 76
Reputation: 3,068

Post » Wed Apr 20, 2016 9:48 am

In the layout-editor you see on top in the ribbon (when you look at the layout and in the tab view) a checkmark with 'Show collision polys'. Check it and you will see red lines that stand for the collision polygones.

If they look a bit messed up. Then double click the sprite to take you to the sprite editor. Choose the last tool on the left. Wich is for changing the collission polygones. Rightclicking and set them to the bouning box, will do in youre situation. Or change them to tour liking.
B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Wed Apr 20, 2016 9:52 am

Oh I will try it, thanks! :)
B
27
S
10
G
3
Posts: 76
Reputation: 3,068

Post » Wed Apr 20, 2016 9:59 am

@99Instances2Go Thats exactly what I have looked for! But at the moment i just have 3 collision points, and I need 4 for my box ^^
Do you know how to add one more point? Thanks!
B
27
S
10
G
3
Posts: 76
Reputation: 3,068

Post » Wed Apr 20, 2016 10:06 am

Right click, add point. Set to bounding box, as i suggested, should set 4 points too.
B
33
S
18
G
28
Posts: 2,493
Reputation: 20,950

Post » Wed Apr 20, 2016 11:14 am

Oh I had to reload C2, now it works. Thank you!
B
27
S
10
G
3
Posts: 76
Reputation: 3,068


Return to How do I....?

Who is online

Users browsing this forum: Artcadev, Uk4dee and 31 guests