Problems to load the game in the Safari (desktop/iOS)

Discussion and feedback on Construct 2

Post » Fri Dec 30, 2016 1:12 pm

The game is not loading totally in the Safari browser.

It starts and goes almost to the end but stops and stay inert indefinitely.

I have published the game with the C2 v240 and the C2 v239.

I am getting only an error in the panel ("Viewport argument key "minimal-ui" not recognized and ignored.") that I believe that is not the real cause.

I also get the following messages in the browser's log:

[Log] [Construct 2] Suspending (c2runtime.js, line 4)
[Log] [Construct 2] Resuming (c2runtime.js, line 4)
[Log] [Construct 2] Suspending (c2runtime.js, line 4)
[Log] [Construct 2] Resuming (c2runtime.js, line 4)
[Log] [Construct 2] Suspending (c2runtime.js, line 4)
[Log] [Construct 2] Resuming (c2runtime.js, line 4)

I have tried to disable the preload sounds but it not worked.

Just to inform: the canvas plugin is the only different thing I am using.

Thanks in advance for any help.
B
74
S
13
G
3
Posts: 995
Reputation: 7,531

Post » Sat Dec 31, 2016 11:49 am

some help?
B
74
S
13
G
3
Posts: 995
Reputation: 7,531

Post » Sat Dec 31, 2016 12:24 pm

Nobody can help unless you provide a .capx and a link to your exported game. You should also test C2 r241 in case we already fixed it.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,228

Post » Sat Dec 31, 2016 6:14 pm

I forgot to say that I also have tried in the 241 version.

I removed the elements form the project, one by one, and I think that I found the issue: a canvas family. When I removed it, the game loads normally. But I don't know if it is an error once the game loads in the Chrome with any problem.
B
74
S
13
G
3
Posts: 995
Reputation: 7,531


Return to Construct 2 General

Who is online

Users browsing this forum: 99Instances2Go, jakezinis and 6 guests