Problems with Mouse behaviors after SAVE & LOAD

Get help using Construct 2

Post » Mon Sep 09, 2013 6:38 pm

Yesterday I already asked this question on the forums, and someone even posted a reply, but unfortunately I can't view it! When I try to open my thread it says that file wasn't found on the server! I need help so I'm asking the same question again, don't mean to spam!

My problem happens after using [Save & Load]! When I save and then load my game, some of the Mouse events stop working (Mouse Over behaviors).

I really need this not only for good looking buttons but also because some of other game's events depend on this!

So, when I put cursor over Button it must change anim's frame to highlight the button. It works fine but after saving and loading the game those behaviors stop working...

How to solve this problem?
B
12
S
2
G
1
Posts: 41
Reputation: 1,442

Post » Mon Sep 09, 2013 8:15 pm

@BigDream

Which version are you running. I had some problems with this but the latest beta has fixed them, at least for me.
B
47
S
16
G
9
Posts: 1,097
Reputation: 11,180

Post » Mon Sep 09, 2013 10:03 pm

I've checked the lastest Beta release's Change Log and look what I've found:

"Bug Fix: Mouse: 'Is over object' did not always work properly after a save/load"

Thank you @spongehammer
B
12
S
2
G
1
Posts: 41
Reputation: 1,442

Post » Tue Sep 10, 2013 5:16 pm

Like always, one problem follows another...

I updated to the latest beta (r143) and Construct crashes as soon as I try to run it! I'm using Steam version...
B
12
S
2
G
1
Posts: 41
Reputation: 1,442


Return to How do I....?

Who is online

Users browsing this forum: Anonnymitet, DeXVinogradov, leena222, tatogame and 18 guests