Progress Bar won't be hidden on layer

For questions about using Classic.

Post » Thu Mar 05, 2009 1:27 am

Don't know whether it's an oversight or by design, but when you hide a layer with the progress bar on it, the bar itself does not disappear with everything else on the layer.

It's not a problem, as you can move the bar out of sight when you need to, but I wondered if it was known.

Cheers.

Sponge.
B
2
S
1
G
3
Posts: 105
Reputation: 1,310

Post » Thu Mar 05, 2009 3:24 am

I think this has to do with the fact that it is a windows control Ive noticed that other windows controls will always be rendered on top of all other object so when you hide the layer that they are on they wont be hidden the same is true for the edit box and possible other windows objects.. I would suggest making your own progress bar with a gradient or a tiled background, not only because you could hide the layer they are on but also they could match you game a little bit better.
B
5
S
2
G
4
Posts: 632
Reputation: 2,829

Post » Thu Mar 05, 2009 1:11 pm

I think this counts as a bug, submit it to the tracker.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Thu Mar 05, 2009 3:12 pm

I think it does, all controls should move/show/hide every frame depending on their layer setting, and I don't think all of them do.
B
3
S
2
G
5
Posts: 1,777
Reputation: 5,529

Post » Fri Dec 09, 2011 7:17 pm

Did this ever get addressed?

I've got a layer with buttons on it, but when I set the layer to invisible, sprite and text gets hidden but the buttons are still there.
B
17
S
3
G
6
Posts: 14
Reputation: 3,850


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 1 guest