Project won't run from root folder

Bugs will be moved here once resolved.

Post » Sat Sep 08, 2012 3:05 pm

It's kinda strange.
I have 5 drives C, D, E, F, G

When I put *.capx file in the root folder on any drive and run it, C2 will crash instantly - except of drive G.

To make it run properly I have to move that file inside to any directory on that drive.

It happens to all capx files and from some time now (not only in R102) - I have deleted so many test files because I though files get corrupted on save.

Any ideas? and why it works fine only on G drive?!


Win 7 64 - C2 R102
ImageImageImageImage
B
156
S
64
G
41
Posts: 2,588
Reputation: 34,601

Post » Sat Sep 08, 2012 7:25 pm

You're right, I can reproduce a crash loading a .capx from C:\. Weird!

It's probably to do with file permissions. By default in Windows Vista or newer applications can't read in system directories like C:\ or C:\Windows. In your case I guess G:\ is a removable drive or secondary hard disk you have permission to access. I guess there must be a bug with C2 when it does not have permission - it should show an error message instead of crash. Will look in to it!
Scirra Founder
B
383
S
224
G
86
Posts: 24,106
Reputation: 190,410

Post » Mon Sep 10, 2012 4:06 pm

Should be fixed in next build, turned out to be a bug with short path names instead of permissions.
Scirra Founder
B
383
S
224
G
86
Posts: 24,106
Reputation: 190,410

Post » Mon Sep 10, 2012 4:47 pm

Great news. Thanks @Ashley
ImageImageImageImage
B
156
S
64
G
41
Posts: 2,588
Reputation: 34,601

Post » Tue Sep 11, 2012 3:27 pm

@Ashley - it's fixed in R103. Works fine from any drive now.
ImageImageImageImage
B
156
S
64
G
41
Posts: 2,588
Reputation: 34,601


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests