Question about frame rate on preview (galaxy tab 3)

Discussion and feedback on Construct 2

Post » Sun Jun 05, 2016 9:36 pm

Does anyone know why I am getting very poor frame rates when I preview on mobile. I created a blank new project and hit preview and when I look at the debug on my galaxy note 3 I am only getting 15-17 frames per second. How accurate is this? am I doomed to have a laggy game if i port to android? Again I tested this with a blank project
B
15
S
4
Posts: 31
Reputation: 1,267

Post » Sun Jun 05, 2016 10:46 pm

Debug has a huge overhead. Add a text object to your layout and set its contents every 0.5 or 1.0 seconds to fps (with no quotations). This will show you your current frames per second without the lag introduced by debug.
B
103
S
38
G
19
Posts: 962
Reputation: 17,996

Post » Mon Jun 06, 2016 12:57 am

smoke84 wrote:Does anyone know why I am getting very poor frame rates when I preview on mobile. I created a blank new project and hit preview and when I look at the debug on my galaxy note 3 I am only getting 15-17 frames per second. How accurate is this? am I doomed to have a laggy game if i port to android? Again I tested this with a blank project


Thats actually very strange lets do a different test. I made a game that has a lot of sprites onscreen with no slowdown. Try my game on your device to see if its laggy

https://play.google.com/store/apps/deta ... ion.undead

I almost 100% sure it won't be even though the game has a lot of onscreen sprites like the bullets you shoot and the zombies coming left and right by the 2nd stage . Also I wrote mobile optimization tips here

optimizing-mobile-games-8-very-critical-tips_t174634

After you have done your test, let me know the results so I can further help you in the future.
Check out my awesome Android Game releases https://play.google.com/store/apps/deve ... ames&hl=en
B
38
S
18
G
24
Posts: 682
Reputation: 16,615

Post » Mon Jun 06, 2016 1:52 am

thank you for the advice guys. i tested using a text object and got 60fps so it must have just been the debug screen slowing me down, phew!
B
15
S
4
Posts: 31
Reputation: 1,267


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 12 guests