Questions about removing permissions from APK?

Get help using Construct 2

Post » Sat Sep 06, 2014 8:45 pm

I followed @Silverforce tutorial about removing unnecessary permissions from an apk, I used the older apktool that he included in the tutorial on an apk compiled with 2.0.2, but noticed after the fact he stated in the comments that a newer version of the apk tool was needed for 2.0.2 compiles. I tested the apk on a device and everything was working correctly, and wanted to see if I could upload to google play, when I uploaded the file it told me that my apk was using services that only work on api level 9+ and I need to change the minsdk to 9 in the manifest, which is a quick fix and would just not support Froyo devices. Not sure exactly why I get this warning on the recompiled apk after removing a couple permissions, is it because I'm using the old apktool he had on the tutorial? Anybody encountered any problems with 2.0.2 compiles using the old apk tool from the tutorial?
B
51
S
18
G
2
Posts: 111
Reputation: 4,611

Post » Sun Sep 07, 2014 12:48 am

Because you need to set the minimum Android version when you compile with CJS.

You can just change the variable in Manifest.xml when you decompile, you will see a line on top like so:

<uses-sdk android:minSdkVersion="10" android:targetSdkVersion="19" />

Change the minSdkVersion to 9+ or whatever you need and build it again with apktool.
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,616

Post » Sun Sep 07, 2014 5:51 am

Silverforce wrote:Because you need to set the minimum Android version when you compile with CJS.

You can just change the variable in Manifest.xml when you decompile, you will see a line on top like so:

<uses-sdk android:minSdkVersion="10" android:targetSdkVersion="19" />

Change the minSdkVersion to 9+ or whatever you need and build it again with apktool.


Thanks for the quick reply @Silverforce , yeah I already recompiled with the corrected manifest before that last post, I was just wondering why you were recommeneding a new apktool version for 2.0.2 compiled apps, if there were any problems that were encountered used the version of apktool you uploaded with 2.0.2 compiles.
B
51
S
18
G
2
Posts: 111
Reputation: 4,611

Post » Sun Sep 07, 2014 10:36 am

twg wrote:
Silverforce wrote:Because you need to set the minimum Android version when you compile with CJS.

You can just change the variable in Manifest.xml when you decompile, you will see a line on top like so:

<uses-sdk android:minSdkVersion="10" android:targetSdkVersion="19" />

Change the minSdkVersion to 9+ or whatever you need and build it again with apktool.


Thanks for the quick reply @Silverforce , yeah I already recompiled with the corrected manifest before that last post, I was just wondering why you were recommeneding a new apktool version for 2.0.2 compiled apps, if there were any problems that were encountered used the version of apktool you uploaded with 2.0.2 compiles.


Some users couldn't build after a recompile with the older apktool. The apktool I posted works fine for me for 2.0.2, but it does not work for Intel XDK built APKs.

So just use whatever works for you, its all the same in the end. Glad it works fine for you!
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,616


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 7 guests