Quick HighScore problem.

Get help using Construct 2

Post » Tue Mar 04, 2014 7:13 pm

matching yours to what mine shows in my zombiy flyer type game i have on start of layout

webstorage | local key "highScore" exists System Set HighScore to WebStorage.LocalValue("highScore")

you can view mine here to see, i crossed out stuff that doesnt apply/wasnt setup just yet

http://game.reconone.info/files/config.png

Game works on computers/my tablet and does save the score

Hope that helps, I know setting up the scoring to work was the worst part for me, or at least the most frustrating
B
6
Posts: 17
Reputation: 332

Post » Tue Mar 04, 2014 10:02 pm

@sotak I'll try that and see if I can get that to work, I'll post back in a few hours with the results :-)
Please Support Ocean Explorer.
http://igg.me/p/735007/x/6915815
B
14
S
4
G
3
Posts: 125
Reputation: 2,645

Post » Wed Mar 05, 2014 12:51 am

@sotak ok that did the same thing. I wonder if the problem is with the Else set Highscore to 0 ? cause when i close the app and start it again it keeps resetting Highscore to 0
Please Support Ocean Explorer.
http://igg.me/p/735007/x/6915815
B
14
S
4
G
3
Posts: 125
Reputation: 2,645

Post » Wed Mar 05, 2014 6:19 am

@bremen It probably something small like mine was once i got it working

You can take a look at my full config here, ive added comments to most areas i feel are helpful.

Not sure if it works without it, but I have my global number HighScore and Score, as well as the local key HighScore, the exact same, as they are case sensitive.


you have both Highscore and highscore...so might be some cross there

Only other thing i can see from that image is you have it ***
Set highscore int(Webstorage.localvalue...etc

Not sure if it works with the int? mine is just "Set HighScore WebStorage...

https://dl.dropboxusercontent.com/u/146 ... flyer.capx
B
6
Posts: 17
Reputation: 332

Post » Wed Mar 05, 2014 7:13 am

@sotak ok thanks again, I'll test it and get back to you, mine is almost identical just a few minor differances. I have changed a couple little things hope it works.
Please Support Ocean Explorer.
http://igg.me/p/735007/x/6915815
B
14
S
4
G
3
Posts: 125
Reputation: 2,645

Post » Wed Mar 05, 2014 11:55 am

maybe a dumb question but does your phone delete cookies when browser is closed?
B
38
S
11
G
5
Posts: 485
Reputation: 5,340

Post » Wed Mar 05, 2014 3:06 pm

If you set it to auto clear yes (I have chrome, not sure if the default browser has it).
B
6
Posts: 17
Reputation: 332

Post » Wed Mar 05, 2014 10:01 pm

@sotak It Works!!! thank you so much, and it was just a small error on my part lol
Please Support Ocean Explorer.
http://igg.me/p/735007/x/6915815
B
14
S
4
G
3
Posts: 125
Reputation: 2,645

Post » Thu Mar 06, 2014 4:25 am

Sweet. I know the feeling looking at it and everything appears perfect, but its that single letter, single word that is missing haha
B
6
Posts: 17
Reputation: 332

Post » Thu Mar 06, 2014 4:31 am

lol yep, thanks again
Please Support Ocean Explorer.
http://igg.me/p/735007/x/6915815
B
14
S
4
G
3
Posts: 125
Reputation: 2,645

Previous

Return to How do I....?

Who is online

Users browsing this forum: Solomon and 8 guests