R 80.2 Frozen Solid After A Few Bumps

Bugs will be moved here once resolved.

Post » Wed Mar 07, 2012 7:54 pm

Heya, I am having a freeze after a few collision in multiple browsers. After a few bumps and updating a text field the game freezes. The game worked perfectly before I updated the art.

Here is the not working version

BAD

Here is the working one. I do not have the capx :( overwrote it.

Old Game Working
B
32
S
9
G
3
Posts: 275
Reputation: 8,063

Post » Thu Mar 08, 2012 12:10 am

I have the same problem with multiple hosted games and the only thing (as far as I am aware) that could be different from previously (perfectly performing) versions is:
-the jquery1.7.1 version may have been changed?
-my hosting provider has changed something?
-I am simply having a bad day and need to go back to bed until tomorrow?
B
16
S
4
G
1
Posts: 18
Reputation: 2,568

Post » Thu Mar 08, 2012 7:32 am

Hey Andy, Maybe its jQuery thing. My game is just on my local machine. I will look up what that is.
B
32
S
9
G
3
Posts: 275
Reputation: 8,063

Post » Thu Mar 08, 2012 7:47 am

Well I just started up C2 this morning and got a crossing lines error for the automated poly collision. I was pretty darn sure that I had fixed mine. It was broken again this morning. Testing now to see results!!! Fingers crossed.
B
32
S
9
G
3
Posts: 275
Reputation: 8,063

Post » Thu Mar 08, 2012 8:04 am

ok in the simple scene above I disabled all the updating of global vars and the updating of text on the screen. That seems to be the problem. I think that I will uninstall C2 and reinstall fresh just in case those pieces were not overwritten with update.
B
32
S
9
G
3
Posts: 275
Reputation: 8,063

Post » Thu Mar 08, 2012 10:55 am

Did fresh install of C2 and things seem to work now. I guess something wasnt overwritten properly. There was some stepping lag running the game for the first.
B
32
S
9
G
3
Posts: 275
Reputation: 8,063

Post » Thu Mar 08, 2012 11:50 am

OK I found what the root of this issue is. When you have an object check for collision with a family type. then Destroy one instance of that family type. CRASH! now I am just making collision checks for each of my bricks and its fine. YAY.
B
32
S
9
G
3
Posts: 275
Reputation: 8,063

Post » Thu Mar 08, 2012 3:08 pm

Ah, thanks for the report, should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,948
Reputation: 178,532


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests