[r100]Blend shaders+Layer rotation

Bugs will be moved here once resolved.

Post » Sun Aug 26, 2012 12:28 am

Upon rotating the layer, blend shaders assigned to sprites resize incorrectly and creates a hall of mirrors effect.

at a layer angle of 45, the width of the shader is double and the height is 0

It only happens to sprites that are not at angle 0

Preview:
https://dl.dropbox.com/u/53374990/ShaderProblem/index.html

Arrows left+right to rotate the layer.

Squares have the 'darken' effect enabled. I've tested with several other blend modes but not all of them.
The square on the left is angled at 0 and is unaffected
middle is angled at 45
right is angled at 0.01


Capx:
https://dl.dropbox.com/u/53374990/ShaderProblem/Shaderproblem.capx


I have latest ati drivers, tried in chrome and ff.
B
28
S
8
G
1
Posts: 469
Reputation: 4,683

Post » Sun Aug 26, 2012 12:32 am

Also I get these black rectangle artifacts where shaders overlap, or just at the edges of the screen.
It's not consistent however.. It was happening in the cap posted above earlier but has stopped now.

I have a feeling it's just me otherwise someone else would have pointed it out.
B
28
S
8
G
1
Posts: 469
Reputation: 4,683

Post » Mon Aug 27, 2012 2:07 pm

Nope, it happens for me too.
B
90
S
30
G
24
Posts: 3,189
Reputation: 32,400

Post » Thu Aug 30, 2012 2:49 pm

Should be fixed in r101, can you confirm?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Thu Aug 30, 2012 3:20 pm

@Ashley yep it's working thanks

New bug though:

If you have a blend shader alongside a colour shader.
For example 'lighten', and 'set colour'

The shaders position seems to be clamped within the viewport

preview

capx
B
28
S
8
G
1
Posts: 469
Reputation: 4,683


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests