[r101] Crash on closing project

Bugs will be moved here once resolved.

Post » Tue Sep 04, 2012 2:17 am

I've had two crashes. The last was r101 after a Save As Single File, then a Close Project. The first was r100. I can't remember the details, but it might have been the same scenario. Crash details at: r101, r100

Crashes removing temporary directory in the Project class destructor.
ImageImage
B
66
S
19
G
121
Posts: 3,194
Reputation: 72,850

Post » Wed Sep 05, 2012 3:17 pm

That's odd, it has trouble deleting some temporary files on exit. I cannot reproduce this problem myself, is there any sequence of steps to make this happen every time?
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,208

Post » Wed Sep 05, 2012 5:17 pm

No, it isn't easily reproducible. That's why I didn't report right away. I was hoping the crash screens indicating the destructor was involved might be enough to investigate at least.
ImageImage
B
66
S
19
G
121
Posts: 3,194
Reputation: 72,850

Post » Wed Sep 05, 2012 6:27 pm

I can see in the code where the error happens, but it doesn't make sense. It empties the entire temporary folder recursively (so its entire contents is removed), then removing the actual folder itself fails with a "folder is not empty" error. So... not sure what to do about it - a repro would help me investigate.
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,208

Post » Wed Sep 05, 2012 6:58 pm

Happens to me too, but not always either.
- Diji
B
23
S
4
G
4
Posts: 54
Reputation: 3,996

Post » Tue Sep 11, 2012 4:28 pm

Is this any better/worse in r103?
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,208

Post » Tue Sep 11, 2012 4:57 pm

Still hard to say. I've noticed something else.

While C2 is open run photoshop and modify sprite frame (from animation folder of project). When You finish save and overwrite image.
Back in C2 in layout sprite will still have original image. Double click/edit animation to go to Edit Image window. Here sprite has already modified texture from PS.

And now two things happening for me.

1. Usually when you close Edit Image sprite in layout will still have original texture (not the same as in edit image) - You have to go back to Edit Image and reload image file for that frame. Now sprite is the same in Edit Image and layout.
C2 saves and close properly.

2. However sometimes - very rarely, when you close Edit Image sprite in layout is automatically changing texture to one from PS (so you don't have to go back to Edit Image and reload texture) and then C2 will save project but won't close (task manager killing time).

It happens first time I run R103, and again some time later.
Did try to reproduce it, making all kind of crazy thing with C2 and PS but no luck.

It probably won't help solving that bug, but maybe someone else have similar experiences :/


Edit: sh*t, wrong post
it goes to this problem -> construct2 not closingshinkan2012-09-11 17:08:03
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170


Return to Closed bugs

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests