[r101] textfields with non-standard fonts appmobi

Bugs will be moved here once resolved.

Post » Thu Aug 30, 2012 10:29 am

I'm not sure if it's a Construct or appMobi issue, so I also posted about it on their forums: http://forums.appmobi.com/viewtopic.php?f=17&t=2098

Textfields with non-standard fonts will cause a black screen when exported to appMobi directCanvas and played on an iDevice.

Testing the same project in the appMobi XDK emulater works, it's just on the iDevice that it fails.

Textfields with standard (eg Arial) fonts work.

Once you have a textfield with a non-standard font, changing the font back to a default font (eg Arial) on the same textfield isn't enough. I actually have to delete and replace the textfield with a new one for it to work.

It would be great if non-standard fonts automatically fall back to a system default font, or at least pop up an error when trying to export.

And yes I know non-standard fonts won't show up on other people's devices. I use them locally anyways so I can design the screen the way I want it to look and then use set web font for other people. Which I know won't work on appMobi but I haven't thought about how to fix that yet... maybe bitmap fonts or as a last resort pngs or using default fonts.wgfunstorm2012-08-30 10:30:01
B
22
S
9
G
5
Posts: 122
Reputation: 5,386

Post » Thu Aug 30, 2012 3:08 pm

Do you mean the 'Text' object or the 'Text Box' object? I guess you mean 'Text', since 'Text Box' is not supported in directCanvas, but I thought 'Text field' usually referred to a text box.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Post » Thu Aug 30, 2012 3:11 pm

Hmm hang on I think I posted too early. Still getting some weird issues... sometimes it works, sometimes it doesn't I'm trying to find the real issue I don't think it's the font anymore. Maybe special characters... hmmm... I'll post again when I have a sample capx for you.wgfunstorm2012-08-30 15:15:47
B
22
S
9
G
5
Posts: 122
Reputation: 5,386

Post » Thu Aug 30, 2012 3:33 pm

Ok this thread was stupid, please close, it wasn't the fonts causing it. See my 2 new thread for the actual issue.
B
22
S
9
G
5
Posts: 122
Reputation: 5,386


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest