R102 regression with DragDrop in Windows 8

Bugs will be moved here once resolved.

Post » Fri Sep 07, 2012 5:24 am

When a project has an object with DragDrop behavior set, the Mouse object's behaviors like On Any Click, On Left Clicked on <Object>, etc,. stopped working in r102 with IE and Windows 8 apps. Please note that this works just fine in r101.

(Took me a while in my large project to isolate this. My complete project became unusable because I had used DragDrop behavior on one object in an unrelated layout).

I have a very simple project illustrating the issue.

This looks like a major regression. Please let me know if you need more information.
B
18
S
7
G
5
Posts: 71
Reputation: 4,991

Post » Fri Sep 07, 2012 9:25 am

"Please note exporting to Windows 8 now requires RTM, so will no longer work on the Release Preview or earlier."

That is written in the release notes for r102, and might be a big part of your problem.

Sorry if this isn't helpful.
B
28
S
6
G
5
Posts: 248
Reputation: 5,463

Post » Fri Sep 07, 2012 2:39 pm

Ah, you're right, the Drag & Drop behavior blocked mouse events on Windows 8. Should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,498

Post » Fri Sep 07, 2012 4:23 pm

@teahousemoon: I am on RTM indeed :)

@Ashley: Thanks for acknowledging.
B
18
S
7
G
5
Posts: 71
Reputation: 4,991

Post » Fri Sep 07, 2012 5:00 pm

Whoops
B
28
S
6
G
5
Posts: 248
Reputation: 5,463

Post » Tue Sep 11, 2012 4:30 pm

Should be working properly in r103, can you confirm?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,498

Post » Tue Sep 11, 2012 7:09 pm

There are still some issues. Here are my observations:
1. The mouse events are now unblocked and DragDrop works with both Mouse and Touch.
2. But now touch events stopped working. You should be able to observe this with the VS2012 simulator(or touch hardware). If you use the Mouse Mode(in simulator), then clicks are registered. But when you switch to Basic Touch Mode(in simulator), clicks are not registered. With r101, mouse and touch both work.
3. Great to see that multi-touch is working now with DragDrop objects.

Edit: Here is a tiny project illustrating the bug.iunkn2012-09-11 23:29:39
B
18
S
7
G
5
Posts: 71
Reputation: 4,991

Post » Wed Sep 12, 2012 5:40 pm

@Ashley: Can you please confirm the above issue?
B
18
S
7
G
5
Posts: 71
Reputation: 4,991

Post » Wed Sep 12, 2012 5:59 pm

@iunkn - your .capx seems to expect that touching 'g2' will fire a mouse event. This is not intended to happen - touch events never fire mouse events, although mouse events can fire touch events when 'Use mouse input' is 'Yes' in the Touch object. On the other hand, the Drag and Drop behavior automatically uses both mouse or touch input. So your .capx appears to be working correctly.

Is there a separate issue or does this explain it?
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,498

Post » Wed Sep 12, 2012 6:55 pm

@Ashley - That explains it.

So in order to detect an object clicked/tapped (mouse or touch) - is it okay to always use "On touched <object>" event rather than using "On Left button clicked on <object>" (with Use mouse input set to Yes)? Or is it advisable to do an OR for above two events?

Thank you.
B
18
S
7
G
5
Posts: 71
Reputation: 4,991

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests