r103 Simulate platform pressing Jump doesn't work

Bugs will be moved here once resolved.

Post » Thu Sep 13, 2012 1:25 pm

My platformer stopped jumping after r103.

I use something like this:

On mouse doubleclick left control -> Simulate platform pressing jump
                                  -> Play animation jump left.

It does nothing but just play the animation.


I also tried manually instead of simulate control .. using
setX = player.X-500
setY = player.Y+1000

It seems to only do the setX part but not the Y part.

Helps?
Krish
Hey! Did you know that you can hire me to make your games?

Click Here to See More
B
21
S
6
G
5
Posts: 391
Reputation: 5,627

Post » Thu Sep 13, 2012 1:36 pm

Simulate jump works fine for me in r103, you should include a .capx so we can try to find out what's causing it. And for the setX/setY; Y+1000 is downwards, so you need to subtract instead of add if you want it to move upwards.
B
27
S
8
G
8
Posts: 903
Reputation: 8,452

Post » Thu Sep 13, 2012 2:06 pm

Here's the capx.

Buggy-Droid


Double click on left half of the game screen to jump
(I haven't written the right jump yet)

It only plays the jump animation but doesnt jump.

The related section in the EventSheet1 is "Mouse is doubleclicking object leftcontrol"


Krish
Hey! Did you know that you can hire me to make your games?

Click Here to See More
B
21
S
6
G
5
Posts: 391
Reputation: 5,627

Post » Thu Sep 13, 2012 2:28 pm

This should never have worked, because there are no Solid or Platform objects in the layout. The Bound To Layout behavior is keeping the object in the layout, but only by overriding its position - technically the object is still in a constant freefall, which is why it can't jump.

I have no idea why this would work before r103, since it's designed wrong. Perhaps a bug that allowed it to jump when in freefall was fixed. You must use solid or platform objects for the player to walk on in order for the platform behavior to work correctly.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,564


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests