[r105] Browser and sound suspending problem

Bugs will be moved here once resolved.

Post » Thu Oct 04, 2012 9:09 pm

1) Create an empty project
2) Add an audio object
3) Add a music file to the project and an event to play it on start of layout
4) Add the browser plugin
5) Add an "on browser suspended" event that sets the music as muted
6) Preview your project
7) Switch to another tab in your browser and then switch back to the game

Expected: when switching back to the game, the music should not play, as it has been muted.

What happened: the music played for a very short time and THEN it was muted.

Thanks for the attention,
Azis
B
5
S
1
Posts: 15
Reputation: 680

Post » Thu Oct 04, 2012 9:48 pm

Actually, I found out it had something to do with some modifications I made to the Audio plugin to add a "Pause" action.

By the way, shouldn't it already have this action?
B
5
S
1
Posts: 15
Reputation: 680

Post » Wed Oct 10, 2012 10:52 am

Can you still reproduce this with the stock Audio object? If so can you share a .capx?

For the record we strongly recommend you don't modify official plugins or behaviors.
Scirra Founder
B
359
S
214
G
72
Posts: 22,949
Reputation: 178,544

Post » Tue Oct 16, 2012 5:38 am

I've just been searching the forums for a pause audio function myself. Did you actually succeed without modding the genuine plugin ?

Please make the answer yes
Using R238 for all examples
B
60
S
17
G
6
Posts: 363
Reputation: 9,125

Post » Wed Nov 07, 2012 7:29 pm

No, I had to do some modifications to the plugin. Although I didn't have to change much, it's tiresome to re-paste the code every time a new Construct version is released.
B
5
S
1
Posts: 15
Reputation: 680


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests