[r120.2] Platform jump behavior

Bugs will be moved here once resolved.

Post » Fri Feb 22, 2013 7:02 am

Link to .capx file (required!):
http://dl.dropbox.com/u/73774002/platformbug.capx

Steps to reproduce:
1. Hold down Platform Right or Left (Arrow keys)
2. Press Platform jump (up)
3. Make sure you held down Right or Left

Observed result:
Sprite goes up, then 90 degrees right/left. No jump arch or fall

Expected result:
Sprite goes up, starts going up right/left, then falls as per normal jump arch.

Browsers affected:
Chrome: yes
Firefox: yes/no
Internet Explorer: yes/no

Operating system & service pack: Windows 7 x64

Construct 2 version: R120beta
Thndr2013-02-22 20:03:58
B
15
S
4
G
4
Posts: 294
Reputation: 3,225

Post » Fri Feb 22, 2013 1:44 pm

Can't reproduce, appears to be a normally working Platform movement. You have pixel rounding and point sampling set though, which makes it look less smooth and might be making you think there's an issue.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Fri Feb 22, 2013 7:40 pm

If you stand by a wall and push up, it goes for the full jump. As you can see in the demo, the jump strength itself makes you go significantly above the platforms.

If you stand by a wall, push right/left into the wall and push jump, you only go as high as the wall then start walking immediately. Even does it without pixel rounding.

It seems to only affect the walls that are 2 tiles high. 1 tile, 3 tile, 4 tiles don't matter. This is at 250 jumpstrength with default settings
At 300 jumpstrength it only affects 3 tile high walls.

My game with platforming configured more detailed, it affects all platforming as 1 2 or even 3 tile high walls it does this (3 tile is the max jump height for that game)

It seems to be anything that is compiled with the [r120.2] build has this issue, as my previously compiled exports do not do this. edit: Just did a test and preview/compile with [r119] does not reproduce the issue I'm having with [r120.2]

Edit: version I am on is [r120.2]. Not just [r120]Thndr2013-02-22 20:03:42
B
15
S
4
G
4
Posts: 294
Reputation: 3,225

Post » Mon Mar 04, 2013 10:11 am

I've got the same bug !
So, How do you fix this problem Thndr ?
B
11
S
1
Posts: 84
Reputation: 1,462

Post » Mon Mar 04, 2013 10:52 am

I reverted back to r119
B
15
S
4
G
4
Posts: 294
Reputation: 3,225

Post » Mon Mar 04, 2013 6:32 pm

I made some changes to the capx to highlight the problem. The player kind of snaps to the edge of the platform sometimes. Seems to happen more frequently in Chrome than in Firefox.
platformJump_r120.2.capx
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,020

Post » Mon Mar 04, 2013 7:57 pm

Thanks but it's a bug with the software:

http://www.scirra.com/forum/r1202-platform-jump-behavior_topic63939.html?KW=
B
15
S
4
G
4
Posts: 294
Reputation: 3,225

Post » Mon Mar 04, 2013 8:03 pm

This bug is a side effect of the fix that was made in r120 in response to my "Platform Behavior Bug (Gliding over platforms)" report. I believe it's lines 596-570 or somewhere around there that causes it. I removed them so I can't check without re-installing.
Image
B
225
S
27
G
13
Posts: 1,774
Reputation: 18,024

Post » Mon Mar 04, 2013 8:08 pm

[QUOTE=Thndr] Thanks but it's a bug with the software:

http://www.scirra.com/forum/r1202-platform-jump-behavior_topic63939.html?KW=[/QUOTE]
Ah I didn't see that thread.
B
54
S
28
G
18
Posts: 1,520
Reputation: 25,020


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests