[r120.2] Platform jump Behavior

Bugs will be moved here once resolved.

Post » Fri Feb 22, 2013 8:13 pm

Original thread was moved to closed bugs. Unless bug is resolved in versions beyond [r120.2]. still persists and easily reproducible and modifiable.

Original Thread: http://www.scirra.com/forum/topic63900.html

Link to .capx file (required!):
http://dl.dropbox.com/u/73774002/platformbug.rar

Contains CAPX (saved in [r119]) along with exports (bug exported from [r120.2])

Steps to reproduce:
0. Open BUG export OR Open CapX file in [r120.2] and Preview
1. Hold Right/Left into a 2 tile high wall
2. Push jump
3. Continue holding left/right

Observed result:
Sprite jumps then immediately goes on platform

Expected result:
Sprite jumps and finishes jump with arch while going right/left.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes

Operating system & service pack: Windows 7 x64

Construct 2 version: [r120.2] x64

====

The issue seems to be affected by changing platforming variables. In the previous thread I modified the jumpstrength in the capx file to 300, and it only affected 3 tile high walls instead of only 2 tile high walls.

I have included the exported project as well both from [r119] and [r120.2], as the bug is noticeable upon export.


Looking into it, it could be the bugfix from r120 which is messing it up:
Bug Fix     Platform: possible 1px hover before triggering 'On land'

It's the only thing that seems to have changed in platforming since [r119]Thndr2013-02-22 20:18:30
B
15
S
4
G
4
Posts: 294
Reputation: 3,225

Post » Mon Feb 25, 2013 4:37 pm

Ah, I see now. Thanks, should be fixed in the next build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests