[r127] Load error

Bugs will be moved here once resolved.

Post » Tue Apr 30, 2013 7:28 am

Link to .capx file (required!):
Private dropbox link sent to support@scirra.com
(Webber.capx)

Steps to reproduce:
1. Load the capx
2.
3.

Observed result:
Error followed by crash

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Project file missing on disk

Condition: FileExists(last_path.c_str())
File: Projects\ProjectFile.cpp
Line: 23
Function: __cdecl ProjectFile::ProjectFile(class FileFolder &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &)
Build: release 127 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 3)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort   Retry   Ignore   
---------------------------

Operating system & service pack:
Win7 64bit

Construct 2 version:
r127
(have gone back to r126 for now)silkc22013-04-30 07:34:55
B
20
S
6
G
2
Posts: 157
Reputation: 3,109

Post » Tue Apr 30, 2013 2:57 pm

I'm afraid the project is corrupt. It's looking for a file called 87535__flasher21__splat.m4a, but the Files project folder is missing entirely (rename the .capx to .zip and you can see).

We can't do anything about this unless you can find out exactly what you did that caused the file to go missing. Otherwise, it's just a missing file and there's nothing else we can do.
Scirra Founder
B
359
S
214
G
72
Posts: 22,951
Reputation: 178,578

Post » Tue Apr 30, 2013 6:06 pm

Not sure on how they got lost, have done nothing abnormal. It's happened recently, because the game had sound the last time I tested.. so I guess r126 lost the files somehow (or it could even be a dropbox issue, I'll try to repeat it).

I had an older version backed up which has got all the sounds so I'll try repair it, thanks for the info. silkc22013-04-30 18:07:38
B
20
S
6
G
2
Posts: 157
Reputation: 3,109


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests