r136 Platform Behavior fix causes other bugs

Bugs will be moved here once resolved.

Post » Wed Jun 26, 2013 5:57 pm

Link to .capx file (required!):
https://dl.dropboxusercontent.com/u/105711543/Platform_Bugs.capx

Just move against a wall when jumping or falling and you'll notice all kinds of problems. Z to jump.

1) Player doesn't jump as quickly nor as high when moving against a wall.
2) Jumping and then moving against a wall sometimes forces the player to fall as soon as it reaches the top.
3) Move against a wall when you start falling and the player instantly reaches maximum falling speed.

*Preventing the player from moving left or right using "Is By Wall" helps but doesn't fully eliminate the problems.Tokinsom2013-06-26 20:25:45
Image
B
234
S
27
G
13
Posts: 1,784
Reputation: 18,274

Post » Wed Jun 26, 2013 8:13 pm

B
18
S
5
G
4
Posts: 568
Reputation: 5,079

Post » Wed Jun 26, 2013 8:18 pm

Thank you for your invaluable input.
Image
B
234
S
27
G
13
Posts: 1,784
Reputation: 18,274

Post » Wed Jun 26, 2013 8:20 pm

I have this bug too. In my game you can swim and jump out of the water, but after the last update, if you do it next to a wall you won't jump as high and can't get out of it.

I actually thought I had messed up somewhere in the code and didn't remember andreyin2013-06-26 20:21:03
B
119
S
41
G
40
Posts: 836
Reputation: 27,792

Post » Wed Jun 26, 2013 10:54 pm

@Tokinsom This is the bug I'm getting as well. Pre r130 I had no issues. Then things bumping into the wall started forcing their way through platforms with the jumpthru behavior. Then this build (r136) I just get stuck the second I hit a second platform tile if I'm already walking on one.

To remedy the older problem I've inserted:
    IF (family)Enemy collides with (family)Wall then Enemy.y=self.y-1

Gravity pulls them through the jumpthru platfrom - at least in my case.damainman2013-06-26 22:55:28
B
47
S
12
G
7
Posts: 341
Reputation: 7,953

Post » Wed Jun 26, 2013 11:02 pm

Jumpthru's are the devil.
B
50
S
20
G
10
Posts: 570
Reputation: 9,792

Post » Thu Jun 27, 2013 1:15 pm

I'm no moderator but please keep bugs in their respective threads ^^; There are like 6 threads on the same two things. This one is just for solids - there are others for the jump-thru bug (although it seems the same fix caused all of them).
Image
B
234
S
27
G
13
Posts: 1,784
Reputation: 18,274

Post » Thu Jun 27, 2013 1:37 pm

Thanks, should be fixed in next build.
Scirra Founder
B
378
S
220
G
84
Posts: 23,871
Reputation: 188,197


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests