[r144] Node-webkit Refuses to Even Work

Bugs will be moved here once resolved.

Post » Mon Sep 16, 2013 4:35 pm

Link to .capx file (required!):
http://megamanrevolution.com/other/bugged.capx

Steps to reproduce:
1. Open the CAPX.
2. Build a Node-webkit export.
3. Try running the EXE export.

Observed result:
The game in question does not open at all aside from running in the background and it just stays there forever. This CAPX example worked before beta r144 and now that it's opened in r144 and exported, it refuses to function.
I don't know if this is coincidence but when I tried building this example CAPX to EXE in an old copy our actual project's node-webkit export, the old game played instead of this, almost as if Construct 2 didn't even include the game's files whatsoever.
In our actual project, I did manage to get the EXE to work, but only after deleting every single event sheet, which is obviously not a viable option.

Expected result:
The game was supposed to run as an EXE.

Browsers affected:
Chrome: N/A
Firefox: N/A
Internet Explorer: N/A

Operating system & service pack:
This has been tested on Windows 8 64-bit, Windows XP SP2 32-bit and Windows 7 64-bit.

Construct 2 version:
r144 64-bit with that patch Ashley released to fix OR blocks since they didn't work without it.corlenbelspar2013-09-16 16:37:04
B
45
S
13
G
1
Posts: 236
Reputation: 4,010

Post » Mon Sep 16, 2013 4:58 pm

I just exported your .capx to node-webkit, and it ran fine.

Please note that I didn't use minify or png recompression.

Using release r144.2
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,557
Reputation: 60,458

Post » Mon Sep 16, 2013 10:34 pm

Oh yeah, it appears r144 was broken in that way. I just got notified of r144.2 and it fixed this issue. Thanks.
B
45
S
13
G
1
Posts: 236
Reputation: 4,010


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests