R164 Construct 2 Check Failure

Bugs will be moved here once resolved.

Post » Sat Mar 15, 2014 4:07 am

Problem Description
Display an error message on startup.

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

ACE table warning: trailing parameters left over, are they meant to be there?

Condition: params.empty()
File: c:\c2\source\exporters\html5\..\..\common\ERAHelpers.h
Line: 312
Function: void __cdecl era::ACETable::Done(void)
Build: release 164 (64-bit) checked
Component: HTML5 exporter
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort Retry Ignore
---------------------------


Attach a Capx
No capx needed or not applicable.

Description of Capx
No capx needed or not applicable.

Steps to Reproduce Bug
  • Install Construct 2 R164
  • Run the Construct 2 from desktop shortcut

Observed Result
Display message "Construct 2 Check Failure"

---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

ACE table warning: trailing parameters left over, are they meant to be there?

Condition: params.empty()
File: c:\c2\source\exporters\html5\..\..\common\ERAHelpers.h
Line: 312
Function: void __cdecl era::ACETable::Done(void)
Build: release 164 (64-bit) checked
Component: HTML5 exporter
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Abort Retry Ignore
---------------------------

When I clicked on retry button, Construct 2 will open. This does not happen on R163.

Expected Result
Construct 2 open normally

Affected Browsers
  • Chrome: (NO)
  • FireFox: (NO)
  • Internet Explorer: NO)

Operating System and Service Pack
Windows 8.1 Enterprise. (I use the free Evaluation Enterprise Edition from MS.)

Construct 2 Version ID
Construct 2 R164
B
83
S
23
G
14
Posts: 389
Reputation: 12,529

Post » Sat Mar 15, 2014 6:14 am

I have the same error with Construct 2 R164 personal Steam at startup on Win7x64SP1 with all updates (all drivers also up to date).
B
9
S
2
Posts: 17
Reputation: 609

Post » Sat Mar 15, 2014 3:40 pm

The same, too. So I roll back to r163 now.
B
109
S
27
G
277
Posts: 4,482
Reputation: 154,924

Post » Mon Mar 17, 2014 2:42 pm

Can't reproduce, works fine here. Looks very much like a problem with a buggy third party plugin.
Scirra Founder
B
399
S
236
G
89
Posts: 24,530
Reputation: 195,402

Post » Mon Mar 17, 2014 4:31 pm

@tumira
@bug_fixer

Thank you Ashely, I had fix it now.
B
109
S
27
G
277
Posts: 4,482
Reputation: 154,924


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests