R171 Sprites disappear after export in Safari

Bugs will be moved here once resolved.

Post » Sun Jun 08, 2014 12:01 pm

Problem Description
I have the same bug in the r171 (32-bit) - viewtopic.php?f=152&t=106539&p=789225#p789225.
The game does not start if you publish in google drive. On my hosting, the game works in Chrome, but fading pictures in safari. preview in safari (all sprites are visible). The problem was also in r170.
link google drive - https://googledrive.com/host/0BztYVkq6T ... index.html
link my host - http://whattemp.ru/game/index.html

Attach a Capx
Sorry I do not have a demo capx I do not know where there is a mistake.

Description of Capx
-

Steps to Reproduce Bug
  • Step 2 - Open CAPX
  • Step 2 - preview in safari (all sprites are visible)
  • Step 3 - export to HTML 5 Website
  • Step 4 - open exported game in safari

Observed Result
Sprites aren't visible

Expected Result
They should be

Affected Browsers
  • Chrome: (NO)
  • FireFox: (NO)
  • Internet Explorer: (NO)
  • Safari: (YES)

Operating System and Service Pack
Windows 7 and service pack 1

Construct 2 Version ID
r171 (32-bit)
B
16
S
4
G
4
Posts: 8
Reputation: 5,587

Post » Sun Jun 08, 2014 2:53 pm

The issue should have been fixed in r171. Are you sure this is not the offline cache still serving up the old broken export? Export again to a different URL and load that in Safari to verify if it's fixed without any chance of using a previous cache.
Scirra Founder
B
399
S
236
G
89
Posts: 24,546
Reputation: 195,436

Post » Sun Jun 08, 2014 3:24 pm

The error remains. Tried to clear the cache wherever possible and exported to the new url.
New link - https://googledrive.com/host/0BztYVkq6T ... index.html
I can send personal messages to Сapx version of the game to check.
B
16
S
4
G
4
Posts: 8
Reputation: 5,587

Post » Sun Jun 08, 2014 11:16 pm

@Slow - that link returns 404 not found for all the image files (check the browser console on desktop), suggesting you simply did not upload all the files.

Also - closing, you need to include a .capx file as per the guidelines for a bug report to be investigated. So far the evidence is there is only a mistake on your part.
Scirra Founder
B
399
S
236
G
89
Posts: 24,546
Reputation: 195,436


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests