[r171] Tizen template out of date (id and package missing)

Bugs will be moved here once resolved.

Post » Mon Jun 09, 2014 4:10 pm

Problem Description
Hi, I'm building some WGT these days using Tizen SDK and I noticed C2 was generating config.xml with missing informations the SDK complains about.
Mainly:
Code: Select all
<tizen:application id="1234567890.YourAppName" package="1234567890" required_version="2.2"/>


source: Tizen Web Application config.xml file

(Also on a side note, it would be nice if we had a list of template [[keywords]] we could use if we want to tweak them ourselves...
And also... maybe... some way to select custom template on export, since (I think) modification of the default ones are overwritten when we update C2....)

Construct 2 Version ID
r171
B
66
S
22
G
14
Posts: 1,484
Reputation: 16,511

Post » Tue Jun 10, 2014 3:59 pm

I tried this the other day and it works fine. Like the tutorial says you need to press save in the IDE and it auto-updates config.xml. Does that fix it for you?
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Wed Jun 11, 2014 8:43 am

@Ashley
Ah! indeed "clean" shows the error and if you "save", tizen will generate a new ID and fill the properties for you.

For a first version it's ok, but the problem is that when you want to update the game you put in the store, you will need the same package ID.
Otherwise the store system doesn't allows you to upload the binary.

You'll have to either copy/paste the ID back into the config.xml or delete/create the app you uploaded on the store.
I think construct2 should generate this ID. Maybe by simply hashing the project ID or just use java type package if possible.
B
66
S
22
G
14
Posts: 1,484
Reputation: 16,511


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests