[R175] Large Music File Glitch

Bugs will be moved here once resolved.

Post » Fri Jul 18, 2014 12:39 am

Problem Description
When, what I'm guessing is a large OGG music file, is played first in the game, no other OGG music files will play.

Attach a Capx
https://www.dropbox.com/s/j20mr04n6eehe ... litch.capx

Description of Capx
This demonstrates the problem.

Steps to Reproduce Bug
  • Open the CAPX.
  • Wait until the first song starts playing.
  • Press Z and viola, the second song won't play at all.

Observed Result
A large OGG music file will bar any other OGG music files from playing.

Expected Result
All music files should be able to play regardless of what is played first.

Affected Browsers
  • Chrome: Yes
  • FireFox: No
  • Internet Explorer: Can't Test Effectively

Operating System and Service Pack
Windows 7 Home Premium 64-bit, Service Pack 1

Construct 2 Version ID
R175 64-bit
B
44
S
12
G
1
Posts: 231
Reputation: 3,875

Post » Fri Jul 18, 2014 7:09 am

Not sure if a bug or not, as it works fine in latest Firefox, so could be a Chromium issue.

At least there is a work-around. Just preload "forest_1" on start of layout, then it works.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
131
S
29
G
81
Posts: 5,328
Reputation: 56,630

Post » Sat Jul 19, 2014 12:06 am

It seems to just be an issue in Chrome and Node-webkit, yeah. Only problem with preloading other music is we've got a ton of music and preloading it all isn't really an option.
B
44
S
12
G
1
Posts: 231
Reputation: 3,875

Post » Sat Jul 19, 2014 12:39 am

I managed to fix it in our audio manager we made by preloading the music as sound effects as soon as they're called because they have a short delay before being called on because of crossfading.
B
44
S
12
G
1
Posts: 231
Reputation: 3,875

Post » Thu Jul 24, 2014 3:53 pm

Likely a Chrome issue if it works in Firefox. Does it work in Chrome after exporting? If so it's the same as a previous Chrome issue we found. Original .capx file is now also missing, and given is probably Chrome issue, closing.
Scirra Founder
B
387
S
230
G
87
Posts: 24,248
Reputation: 192,238


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest