[r176] Custom Movement Set Overall Speed Bug

Bugs will be moved here once resolved.

Post » Wed Aug 13, 2014 4:37 pm

Problem Description
when using "set overall speed" it seems to apply only the X velocity and does not set the Y.

Attach a Capx
Attached!

Description of Capx
Sets the angle of the sprite to a random angle. Sets the custom movement angle of motion to the sprite's angle. Sets the overall speed to 20.

Steps to Reproduce Bug
  • try to set the overall speed

Observed Result
Only the X is set and the sprite moves horizontally regardless of angle.

Expected Result
It should set both the X and Y and then move properly.

Affected Browsers
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
____ Your operating system and service pack ____

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____
You do not have the required permissions to view the files attached to this post.
B
31
S
7
G
1
Posts: 80
Reputation: 2,550

Post » Wed Aug 13, 2014 4:55 pm

Closing as not a bug: you can't set the angle of motion when the object is stopped, it has no effect. The object stores the movement as dx and dy values and when it's stopped these are both 0, so there is no angle. Simply swap round the actions so you set the speed first, then the angle can be applied and it works.
Scirra Founder
B
402
S
238
G
89
Posts: 24,631
Reputation: 196,029

Post » Wed Aug 13, 2014 4:56 pm

Ah! Thanks for the quick reply!
B
31
S
7
G
1
Posts: 80
Reputation: 2,550


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests