R184 Node-webkit Mac Export broken

Bugs will be moved here once resolved.

Post » Thu Oct 09, 2014 5:50 pm

Problem Description
exporting to node-webkit does not work for Mac. The resulting .app does not work.

Attach a Capx
I opened an example project and built it.

Description of Capx
This is just the empty sd project built into C2.

Steps to Reproduce Bug
  • Export for node-webkit

Observed Result
the app will not run. It makes the taskbar shake like it was about to put an icon there but then dissapears.

Expected Result
The app should run.

Affected Browsers
  • Chrome: (NO)
  • FireFox: (NO)
  • Internet Explorer: (NO)

Operating System and Service Pack
MAC 10.9.5

Construct 2 Version ID
R184 64-bit Steam
You do not have the required permissions to view the files attached to this post.
B
31
S
7
G
1
Posts: 80
Reputation: 2,550

Post » Thu Oct 09, 2014 11:00 pm

Never mind! Turns out it was a permission problem!

80Bit let me know the following which turned out to be true!

chances are the permissions get bunked when you bring it from Parallels / VMWare into OSX.

1. Open terminal
2. Type sudo chmod -R 0755 path/to/file/yourfile.app
3. Type password.
4. Enjoy. :)
B
31
S
7
G
1
Posts: 80
Reputation: 2,550

Post » Thu Oct 16, 2014 11:12 am

or download batchmod and open up permissions without terminal :)
B
37
S
6
G
1
Posts: 301
Reputation: 2,865

Post » Thu Jun 02, 2016 4:40 pm

Excellent it's work
B
23
S
12
G
4
Posts: 31
Reputation: 4,591

Post » Thu Jun 09, 2016 9:54 am

Hi :) I tried the terminal command way first and yes I changed the path ;) but I didn't manage to make it work. But @damjancd =O omg batchmod worked perfectly :)))))) thank you so much!!!
Chris Hinz

Design, visual development and illustration

www.hinz-art.com
B
7
S
1
Posts: 51
Reputation: 544

Post » Thu Jun 16, 2016 11:42 am

Wohoo I helped :) Finally :)
Glad it works
B
37
S
6
G
1
Posts: 301
Reputation: 2,865


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests