R184 - NodeWebKit visual bug on exported EXE.

Bugs will be moved here once resolved.

Post » Sat Oct 11, 2014 12:55 pm

Problem Description
Since R184 release, there are visuals issues on tiled sprites but only on the NodeWebKit exported EXE.

Attach a Capx
https://dl.dropboxusercontent.com/u/13847313/Scirra/NodeWebkit_VisualBug.capx

Description of Capx
A simple sprite (with platform controller) in front of a background made of small tiled sprites.

Steps to Reproduce Bug
  • Open the capx and export it to a Node Webkit PC executable.
  • Launch the EXE and move the bubble to scroll

Observed Result
Vertical white lines appear in the background

Expected Result
No vertical lines should appear

Affected Browsers
    Only visible on a NodeWebKit executable.

Operating System and Service Pack
Win7 pro - Service pack 1

Construct 2 Version ID
R184
B
72
S
21
G
12
Posts: 314
Reputation: 12,111

Post » Sun Oct 12, 2014 9:48 am

I also get the same on Win7 Ultimate SP1 and GTX 560 Ti TOP. Desktop resolution is 1680x1050 if that makes any difference.

However if I change Letterbox scale to Letterbox integer scale or Fullscreen scaling to low or Downscaling to medium the problem disappears.
Last edited by Katala on Sun Oct 12, 2014 12:04 pm, edited 1 time in total.
B
34
S
9
G
3
Posts: 517
Reputation: 5,226

Post » Sun Oct 12, 2014 11:15 am

Yep you're right.
It seems the problem is only on this set up :
-Fullscreen Letter scale
-Fullscreen High Quality
-Downscaling High quality

Maybe it's related with that R184 change :
'If 'Downscaling' is 'High quality', Construct 2 now always ensures the last frame of animations is also padded out to a power-of-two size, ensuring it gets a mipmap and displays with the same quality as the rest of the animation.'
B
72
S
21
G
12
Posts: 314
Reputation: 12,111

Post » Sun Oct 12, 2014 12:29 pm

Can't reproduce here.

Closing as won't fix even if there is a problem. Tiling sprites for the background is the most inefficient way of doing that as described in Performance Tips:

Using Sprites instead of Tiled Backgrounds
Creating too many objects can cause slowdowns, and a common mistake is to use grids of Sprite objects instead of Tiled Background objects. This is similar to using tilemaps inappropriately. For example, a 20x20 grid of sprites has 400 objects, which is a significant impact on the object count. A single tiled background can replace the grid of sprites and it only counts as a single object. Tiled backgrounds are specially optimised for repeating their texture so in this case it is literally 400 times more efficient than the grid of sprites. Always use Tiled Backgrounds instead of repeating Sprites wherever possible.


Use a tiled background instead, which also guarantees seamless rendering.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600

Post » Sun Oct 12, 2014 1:05 pm

@Ashley I've used a lot of sprites to accentuate the effect.
I've changed my capx and let just 3 sprite blocs. The issue is still here. (not on your computer but on Katala's one and mine.)
And really, I don't understand why you say : "Closing as won't fix even if there is a problem"
I don't know how to take it.
B
72
S
21
G
12
Posts: 314
Reputation: 12,111

Post » Sun Oct 12, 2014 9:44 pm

You can't get seamless rendering with adjacent sprites unless you use letterbox integer scale, point sampling and pixel rounding. This is often repeated on the forums and for the same reason inserting the Tilemap object recommends you use those settings. Otherwise you may get seams from floating point rendering which is a normal result in computer graphics.

Also I am not sure why you changed the downscaling mode from the default. Are you aware of the significant memory use implications and the narrow cases in which high quality mode is truly recommended? Have you observed rendering quality changes that justified it?
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests