[R186.2] Ejecta error on suspend / can't resume

Bugs will be moved here once resolved.

Post » Mon Nov 03, 2014 10:23 am

Problem Description
App crashes on suspend (home button pressed). Can't resume.

Attach a Capx
Attached basic empty project with 2 sprites.

Description of Capx
Empty project that displays 2 sprites.

Steps to Reproduce Bug
  • Export to Ejecta unminified. Copy to App folder. Run in Xcode simulator. Press home button (Shift+Command+H).
  • Debug area logs error. (see below)
  • Resuming the app hangs. The same behaviou is found on hardware (iPad2)

Observed Result
Degug area states:
Code: Select all
2014-11-03 10:00:15.958 Super Golf World[787:90b] TypeError: null is not an object (evaluating 'context["suspend"]') at line 15161 in index.js


Looking at line 15161 in index.js, the code is:
Code: Select all
   instanceProto.onSuspend = function (s)
   {
      if (this.playinbackground)
         return;
      if (!s && context["resume"])
         context["resume"]();
      var i, len;
      for (i = 0, len = audioInstances.length; i < len; i++)
         audioInstances[i].setSuspended(s);
LINE 15161>>>   if (s && context["suspend"])
         context["suspend"]();
   };


Expected Result
App should be able to resume from suspend without crashing. Worked fine on R184 and earlier versions.

Affected Browsers
Not applicable/iOS bug

Operating System and Service Pack
Win8, 32 bit

Construct 2 Version ID
R186.2
You do not have the required permissions to view the files attached to this post.
B
24
S
7
G
1
Posts: 186
Reputation: 2,716

Post » Mon Nov 03, 2014 2:15 pm

Oops, thanks for the report, should be fixed in the next build.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Fri Nov 21, 2014 7:29 am

@Ashley I am facing the same issue with my Windows Universal App 8.1(Phone).

Whenever I press the WP Menu button to go to main screen and come back to the game, the App crashes.
This has been happening with all earlier builds too.

One observation is that , this started occurring after adding the Audio Object to the project. And happens only once a Sound file starts playing. After that it doesnt matter if the Sound is playing or not. The App just doesnt Resume back.

Will test it on R189 built today.
Create your own Isometric Runner Game using C2:

Image

Check out my game "Last of the Survivors":
Play Store
App Store
B
57
S
11
G
2
Posts: 412
Reputation: 5,189

Post » Fri Nov 21, 2014 9:26 am

@SamRock - this is a closed bug report, the problem was fixed in r187. Please only test the latest version of C2.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Mon Nov 24, 2014 5:07 pm

Ashley wrote:@SamRock - this is a closed bug report, the problem was fixed in r187. Please only test the latest version of C2.


Hi @Ashley,

I have tried this with the latest C2 version and still the compiled APP on my Windows Phone crashes. Also there are couple of JQuery errors that show up while running. I will create another thread for this:

'WWAHOST.EXE' (Script): Loaded 'Script Code (MSAppHost/2.0)'.
Exception was thrown at line 2, column 10423 in ms-appx://5c4f7c91-0785-40c6-aa1a-e2aa55a4f001/jquery-2.1.1.min.js
0x800a139e - JavaScript runtime error: SyntaxError
Exception was thrown at line 2, column 10648 in ms-appx://5c4f7c91-0785-40c6-aa1a-e2aa55a4f001/jquery-2.1.1.min.js
0x800a139e - JavaScript runtime error: SyntaxError
Create your own Isometric Runner Game using C2:

Image

Check out my game "Last of the Survivors":
Play Store
App Store
B
57
S
11
G
2
Posts: 412
Reputation: 5,189


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 5 guests