r190 Global Layer v Web Font Incompatibility

Bugs will be moved here once resolved.

Post » Sun Dec 07, 2014 1:50 pm

Hi @Ashley, just for your info as this might be a bug with r191... I have been messing around with LD31 using r191 and I have found that my web fonts were not consistently loading / triggering the on-created set web font command. They seem to miss being loaded about 5% of the time and I have no idea why... So, I tried to roll back to r190 to see if the problem lies with r191 rather than some files I might be using and I received the following warning, so I cannot test to see if this is just something else I've made a mistake with or whether it's a problem with the beta editor.

fail to load warning.png
You do not have the required permissions to view the files attached to this post.
A big fan of JavaScript.
B
76
S
20
G
74
Posts: 2,253
Reputation: 46,480

Post » Sun Dec 07, 2014 1:59 pm

Rolling back to an older version after saving your project is never officially supported. If you are editing the project files directly to allow C2 to open it, then you are risking exactly this kind of issue. Condition 18 in the Browser object is the new 'Supports requesting fullscreen' condition, so presumably you added it in r191, saved, then tried to open in r190 where the condition does not exist. This is nothing to do with this bug report here.
Scirra Founder
B
399
S
236
G
89
Posts: 24,530
Reputation: 195,402

Post » Sun Dec 07, 2014 2:27 pm

OK, thanks @Ashley. I suspect that the problem was that sometimes the web fonts take a long time to load rather than it being a failure to load them. This version of the editor is far more stable - no crashes or evident slow downs at all.
A big fan of JavaScript.
B
76
S
20
G
74
Posts: 2,253
Reputation: 46,480

Post » Mon Dec 08, 2014 2:19 pm

Awesome. Closing as fixed.
Scirra Founder
B
399
S
236
G
89
Posts: 24,530
Reputation: 195,402

Post » Mon Dec 08, 2014 3:50 pm

Nope, i have the same problem
Image
B
23
S
5
G
2
Posts: 30
Reputation: 1,618

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests