[r197] Music functions broken

Bugs will be moved here once resolved.

Post » Wed Feb 18, 2015 2:16 am

Problem Description
I've been using a piece of code by @blackhornet to make the music in my game fade out/in.

This works just fine on versions up to r196.2, but on the recently released version r197, it's broken. It's probably related to the "Audio: unable to set music volume in Chrome for Android" bugfix.

Attach a Capx
https://dl.dropboxusercontent.com/u/238 ... Test3.capx

Description of Capx
The .capx contains the piece of code used to fade the songs.

Steps to Reproduce Bug
  • Step 1 - Run .capx

Observed Result
Next song never plays.

Expected Result
The next song should play when the fade is over (db is -30)

Affected Browsers
All of them.

Operating System and Service Pack
Win 8.1

Construct 2 Version ID
Beta r197
B
125
S
43
G
41
Posts: 849
Reputation: 28,260

Post » Mon Feb 23, 2015 12:54 pm

Thanks, good catch. Should be fixed in next beta.
Scirra Founder
B
399
S
236
G
89
Posts: 24,519
Reputation: 195,361

Post » Mon Feb 23, 2015 11:45 pm

Phew, thanks! I seriously thought that I would have to rewrite the entire thing and that I was the one messing it up haha. Cheers!
B
125
S
43
G
41
Posts: 849
Reputation: 28,260

Post » Tue Feb 24, 2015 3:18 am

@andreyin - any chance the code from @blackhornet is posted on the forum? I couldnt find anything.. :D Thanks!
Made Cosmochoria - www.cosmochoria.com
Currently working on Slayaway Camp - www.slayawaycamp.com
B
27
S
8
G
3
Posts: 384
Reputation: 5,020

Post » Tue Feb 24, 2015 3:44 am

Probably this one: viewtopic.php?t=85960&start=0
ImageImageImage
B
71
S
22
G
247
Posts: 3,756
Reputation: 137,558

Post » Tue Feb 24, 2015 4:57 pm

80bit wrote:@andreyin - any chance the code from @blackhornet is posted on the forum? I couldnt find anything.. :D Thanks!


blackhornet wrote:Probably this one: viewtopic.php?t=85960&start=0


Yes, that's exactly it!
B
125
S
43
G
41
Posts: 849
Reputation: 28,260

Post » Tue Feb 24, 2015 8:50 pm

@andreyin @blackhornet - thanks dudes :)
Made Cosmochoria - www.cosmochoria.com
Currently working on Slayaway Camp - www.slayawaycamp.com
B
27
S
8
G
3
Posts: 384
Reputation: 5,020

Post » Tue Mar 10, 2015 12:09 am

Hi
Do you managed to get it work?
B
92
S
30
G
11
Posts: 654
Reputation: 11,707

Post » Tue Mar 10, 2015 3:51 am

Iolva wrote:Hi
Do you managed to get it work?


Yep, it's working just fine after r198.
B
125
S
43
G
41
Posts: 849
Reputation: 28,260

Post » Tue Mar 10, 2015 4:04 am

Hmm
B
92
S
30
G
11
Posts: 654
Reputation: 11,707

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests