[r197] Textbox pin/drag not working

Bugs will be moved here once resolved.

Post » Fri Mar 06, 2015 3:36 pm

Problem Description
Pinning textboxes while using drag drop behaviour on a sprite or 9-patch will cause the text to "fall" out of the textbox.

Attach a Capx
Textbox_pin_drag_problem.capx


Description of Capx
Two textbox pinned to a 9-patch with drag drop

Steps to Reproduce Bug
    Drag 9-patch

    Observed Result
    Text falls out of textbox.

    Image

    Expected Result
    Well....:D

    Affected Browsers
    • Chrome: (YES and NW.js)
    • FireFox: (Don't know)
    • Internet Explorer: (NO) But the textboxes are all over the place, trying to keep up with the 9-patch, but the text stays in place.

Operating System and Service Pack
Windows 7

Construct 2 Version ID
r197
You do not have the required permissions to view the files attached to this post.
B
44
S
11
G
2
Posts: 1,181
Reputation: 6,816

Post » Mon Mar 09, 2015 1:50 pm

This is a bug in Chrome (and a pretty weird one!), not Construct 2. It works correctly in Firefox and IE11 here, as well as Chrome Canary, so it looks like Google already fixed it and it just needs to make its way down to a stable release.
Scirra Founder
B
381
S
222
G
84
Posts: 23,978
Reputation: 189,176

Post » Mon Mar 09, 2015 6:57 pm

Ahh ok that cool, ill just keep an eye out for it. thanks
B
44
S
11
G
2
Posts: 1,181
Reputation: 6,816

Post » Thu Apr 16, 2015 12:22 am

Just letting others know that the problem with textbox text is effected in the Moveto behavior also. When the textbox begins it move across the screen (I only have it moving to a new X with the same Y), it is as if the text itself has gravity pulling it down out of the textbox and it keeps falling until the textbox frame stops moving. The text reaches the X position but now has fallen to a new lower Y height. If I resize the Chrome window even a little, the text refreshes in the center of the textbox again.

Just update Chrome and the problem is gone. Not sure why I did not get an auto update.
B
66
S
9
G
8
Posts: 24
Reputation: 8,604

Post » Sat Oct 24, 2015 11:22 am

Ashley wrote:This is a bug in Chrome (and a pretty weird one!), not Construct 2. It works correctly in Firefox and IE11 here, as well as Chrome Canary, so it looks like Google already fixed it and it just needs to make its way down to a stable release.

This seems to have been fixed in Chrome now, however my program runs in NWjs v0.12.0 and the problem still exist here is it possible to get it fixed here as well?
B
44
S
11
G
2
Posts: 1,181
Reputation: 6,816

Post » Sat Oct 24, 2015 12:44 pm

@nimos100 - no, the bug is in the Chrome browser engine not our code, so the only fix is to update. A new NW.js version should be along soon.
Scirra Founder
B
381
S
222
G
84
Posts: 23,978
Reputation: 189,176

Post » Sat Oct 24, 2015 1:43 pm

Ashley wrote:@nimos100 - no, the bug is in the Chrome browser engine not our code, so the only fix is to update. A new NW.js version should be along soon.

What do you mean?

The bug is not in Chrome, meaning if I drag it there it works, so Chrome must have been fixed. However if I do the same in NWjs the bug is still there and the text falls out of the textbox or do I misunderstand what you mean or do you mean that you are not developing NWjs so you can't fix it?
B
44
S
11
G
2
Posts: 1,181
Reputation: 6,816

Post » Mon Oct 26, 2015 12:16 pm

The bug was in Chrome. NW.js is based on an older version of Chrome.
Scirra Founder
B
381
S
222
G
84
Posts: 23,978
Reputation: 189,176


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests