r201 bug with opening a source

Bugs will be moved here once resolved.

Post » Thu Apr 02, 2015 7:34 am

Problem Description
Bug with a launch my source

Attach a Capx
i can't

Description of Capx
Err

Steps to Reproduce Bug
  • Open an example
  • all)

Observed Result
---------------------------
Construct 2 Check failure
---------------------------
Check failure! This is probably a bug:

Plugin of non-world type specified 'rotatable'

Condition: !(plugin_type == era::pt_objecttype && rotatable)
File: Projects\ObjectType.cpp
Line: 37
Function: __cdecl ObjectType::ObjectType(class Project &,class ObjectFolder &,class Plugin *,const class std::basic_string<wchar_t,struct std::char_traits<wchar_t>,class std::allocator<wchar_t> > &,unsigned __int64)
Build: release 201 (64-bit) checked
Component: Construct 2 IDE
(Last Win32 error: 0)

You are using a 'checked' release of Construct 2, intended for testing, which causes certain errors to be reported this way. Hit Ctrl+C to copy this messagebox - it's useful information for the developers, so please include it with any bug reports! Click 'Abort' to quit (unsaved data will be lost!),'Retry' to turn off messages for this session and continue, or 'Ignore' to continue normally.
---------------------------
Прервать Повтор Пропустить
---------------------------
and the project opened
Expected Result
hmm.. what my game opened?))

Affected Browsers
This bug with a launch, not preview

Operating System and Service Pack
Win7

Construct 2 Version ID
New, r201

[b]Screen
Image
B
27
S
6
G
2
Posts: 185
Reputation: 2,961

Post » Thu Apr 02, 2015 11:56 am

This is probably a bug with a third-party plugin. Check all your plugins are installed correctly and up-to-date. We can't investigate any further unless you provide a .capx that demonstrates this problem without requiring any third party plugins.
Scirra Founder
B
383
S
225
G
86
Posts: 24,134
Reputation: 190,601


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest