[r202] NWjs Open browser URL

Bugs will be moved here once resolved.

Post » Wed Apr 15, 2015 11:56 pm

Problem Description
Not really sure if this is a bug or not, so if someone could double check it, it would be great. But using NWjs Open browser doesn't seem to work for me.

If I preview it In Chrome or IE, it doesn't open the URL and no error is given, nothing happens.

In NWjs if I use a path like "C:\Users\" or an URL, I get the following error:
Image
However in NWjs it does actually work in both cases. Even though it gives the error message.

Attach a Capx
Not really needed for testing.
Just add NWjs to a project and then use Open browser with an url.

Description of Capx
Just opens an url using NWjs open browser functionality

Steps to Reproduce Bug

Observed Result
Gives error message. However works in NWjs, but not Chrome or IE

Expected Result
That it didn't give an error message.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (Don't know)
  • Internet Explorer: (YES)
(And NWjs)

Operating System and Service Pack
Windows 7

Construct 2 Version ID
r202
B
44
S
11
G
2
Posts: 1,181
Reputation: 6,816

Post » Thu Apr 16, 2015 9:58 pm

Line 478 in node.js they create a stream as a global and because of strict mode it errors out.

edit : Just wanted to add that I've actually encountered this error a few times :mrgreen:
B
10
S
2
G
1
Posts: 202
Reputation: 1,545

Post » Tue Apr 21, 2015 1:07 pm

Closing, please always attach a .capx to every report, it is mandatory. I tried a quick test using the Browser object's 'Open URL in new window' and it worked in both Chrome and NW.js without any error appearing. I am guessing you did something different to me, which is why we always need your .capx.
Scirra Founder
B
383
S
224
G
86
Posts: 24,106
Reputation: 190,410


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest