[r210] Windows 10 export build issues

Bugs will be moved here once resolved.

Post » Wed Jul 29, 2015 9:13 am

Problem Description
After building a Windows 10 export for VS2015, you can open the project in VS2015, however the package.appxmanifest only opens in Code Mode and not the designer where you need to upload your App icons and stuff like from Windows 8. Also I get the build error as you can see in the screenshot below, but once again even when I change the build version to 10.0.10240.0, it still giving me the same build error.


Image

Operating System and Service Pack
Windows 10 Professional Build 10240

Construct 2 Version ID
r210
Image
B
81
S
16
G
4
Posts: 501
Reputation: 8,934

Post » Wed Jul 29, 2015 11:17 pm

Never mind. Figured it out myself..

For those that have an earlier build of VS 2015 RTM or Community ( Prior to July 29th, 2015).. You will need to update your existing copy of VS 2015. Just download another setup file from https://www.visualstudio.com/downloads/download-visual-studio-vs

Image
Image
B
81
S
16
G
4
Posts: 501
Reputation: 8,934

Post » Sun Aug 02, 2015 8:06 pm

I just installed VS Community today (August 2) and I am having the same issue. I'll reinstall with just the options you have and see if that makes a difference.
B
34
S
12
G
3
Posts: 91
Reputation: 4,725

Post » Tue Aug 04, 2015 8:26 pm

It should make the difference.. All Microsoft did was unlocked the ability to export when Windows 10 released on July 29th.
Image
B
81
S
16
G
4
Posts: 501
Reputation: 8,934

Post » Tue Aug 04, 2015 9:43 pm

I reinstalled VS Community, exported my project as Windows 10 Universal App, and opened the .sln file.
https://onedrive.live.com/redir?resid=9 ... hoto%2cpng for the image of the erro.

Unable to Load Manifest Designer
The Manifest cannot load because one or more of the files(s) has errors. Fix the errors then try the operation again.
B
34
S
12
G
3
Posts: 91
Reputation: 4,725

Post » Fri Aug 07, 2015 1:54 pm

The final Visual Studio 2015 RTM version made a few changes to the Windows 10 project format. I've updated the next build to use the latest format, so that should fix it.
Scirra Founder
B
387
S
230
G
87
Posts: 24,249
Reputation: 192,240

Post » Fri Aug 07, 2015 4:36 pm

sbucci wrote:I reinstalled VS Community, exported my project as Windows 10 Universal App, and opened the .sln file.
https://onedrive.live.com/redir?resid=9 ... hoto%2cpng for the image of the erro.

Unable to Load Manifest Designer
The Manifest cannot load because one or more of the files(s) has errors. Fix the errors then try the operation again.


Hi sbucci,

Check in your project if the Version textfield info follow this template 1.0.0.0 (can be any numbers you want but have to be 4 digits separated by dot)
You will also need to fill the ID, Description and Author, or it can cause errors during the package.appxmanifest loading and project build in Visual Studio

Sincerly,
Cédric Ricci
B
30
S
7
G
4
Posts: 10
Reputation: 7,193

Post » Fri Aug 07, 2015 5:45 pm

Ashley wrote:The final Visual Studio 2015 RTM version made a few changes to the Windows 10 project format. I've updated the next build to use the latest format, so that should fix it.



Thanks, I'll give it another go.
Image
B
81
S
16
G
4
Posts: 501
Reputation: 8,934

Post » Sat Aug 08, 2015 12:25 pm

That did it Cedric
B
34
S
12
G
3
Posts: 91
Reputation: 4,725

Post » Thu Aug 13, 2015 10:41 pm

I am still getting the version error that others had. I have tried re-installing VS, my version number is set to 1.0.0.0, I have a Author/Description set. Any other suggestions? (I am using the latest Scirra version)
B
41
S
17
G
8
Posts: 484
Reputation: 8,261

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 8 guests